WordPress.org

Ready to get started?Download WordPress

Forums

WordTwit Twitter Plugin
[resolved] [Plugin: WordTwit] Breaking AJAX while creating new posts in WordPress 3.1.1 (6 posts)

  1. Leo Newball
    Member
    Posted 3 years ago #

    When creating a new post, WordTwit breaks all of the functions within creating a new post. Trying to create a new link, add a new category, or even add tags, do not work.

    I used both Chrome and Firefox on OSX 10.6.7, and here are the following errors I get from each browser.

    Chrome (10.0.648.204):

    Uncaught TypeError: Object function (options) {
    		if (!$(this).length) {
    			return this;
    		}
    
    		$(this)
    			.data('fancybox', $.extend({}, options, ($.metadata ? $(this).metadata() : {})))
    			.unbind('click.fb')
    			.bind('click.fb', function(e) {
    				e.preventDefault();
    
    				if (busy) {
    					return;
    				}
    
    				busy = true;
    
    				$(this).blur();
    
    				selectedArray = [];
    				selectedIndex = 0;
    
    				var rel = $(this).attr('rel') || '';
    
    				if (!rel || rel == '' || rel === 'nofollow') {
    					selectedArray.push(this);
    
    				} else {
    					selectedArray = $("a[rel=" + rel + "], area[rel=" + rel + "]");
    					selectedIndex = selectedArray.index( this );
    				}
    
    				_start();
    
    				return;
    			});
    
    		return this;
    	} has no method 'build'
    (anonymous function):1
    c.b.extend.readyload-scripts.php:29
    c.u

    Firefox (4.0):

    Error: $.fn.fancybox.build is not a function
    Source File: http://***.com/wp-content/plugins/wordtwit/js/fancybox_1.2.5.js?ver=3.1.1
    Line: 16

    This is a huge must fix, please soon :-)

  2. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    Can't seem to replicate the bug— are you running WordTwit 2.6?

  3. Leo Newball
    Member
    Posted 3 years ago #

    Yes, I should have also added I'm also on a WordPress MU setup.

    Forgive me for failing to mention that the first round. (Meep!)

  4. BraveNewCode Inc.
    Member
    Plugin Author

    Posted 3 years ago #

    Ok. Multisite on 3.1.1, fresh multisite, or upgraded from MU to multisite?

  5. Leo Newball
    Member
    Posted 3 years ago #

    Fresh multisite, upgrade was from 3.1 MU to 3.1.1 MU.

  6. Leo Newball
    Member
    Posted 3 years ago #

    Problem solved - it was caused by my own theme, calling Fancybox in the admin area. JavaScript collided with each other. Updating and fixing on my end.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags