WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wordTube] The Flash player is not detected. (52 posts)

  1. lowercase001
    Member
    Posted 4 years ago #

    Quick fix - drop Player.swf and yt.swf files into your wordpress installations root directory and all will work fine.

  2. tonyzeoli
    Member
    Posted 4 years ago #

    @lowercase001

    Nope, that didn't work for me. My path is still hard coded to the uploads folder. There's nothing I can do right now. Tried your method and that's not working.

    @alex, please help!!!!!

  3. tonyzeoli
    Member
    Posted 4 years ago #

    Here's the code I see in the settings.php file of Wordtube

    <div id="generaloptions">
    
    			<h2><?php _e('General Options','wpTube'); ?></h2>
    
    			<form name="generaloptions" method="post">
    
    			<?php wp_nonce_field('wt_settings') ?>
    
    			<input type="hidden" name="page_options" value="path,usewpupload,uploadurl,deletefile,xhtmlvalid,activaterss,rssmessage" />
    
    				<table class="form-table">
    
                        <tr valign="top" <?php echo $border; ?>>
    
                            <th scope="row"><?php _e('Path to JW Media Player', 'wpTube'); ?></th>
    
        					<td>
    
                                <input type="text" size="60" name="path" value="<?php echo $wt_options['path']; ?>" />
    
                                <span class="description"><?php _e('Upload the flash player to your blog. Default is', 'wpTube'); ?> <code>wp-content/uploads/player.swf</code></span> 
    
                            </td>
    
        				</tr>
    
    					<tr>
    
    						<th valign="top"><?php _e('Upload folder','wpTube') ?>:</th>
    
    						<td>
    
    							<label><input name="usewpupload" type="radio" value="1" <?php checked( true, $wt_options['usewpupload']); ?> /> <?php _e('Standard upload folder : ','wpTube') ?></label><code><?php echo get_option('upload_path'); ?></code><br />
    
    							<label><input name="usewpupload" type="radio" value="0" <?php checked( false, $wt_options['usewpupload']); ?> /> <?php _e('Store uploads in this folder : ','wpTube') ?></label>
    
    							<input type="text" size="50" maxlength="200" name="uploadurl" value="<?php echo $wt_options['uploadurl'] ?>" />
    
    						</td>
    
    					</tr>

    I don's see how you can change the path, given it's a php call. I'm not an expert, so I'm not going to touch it, but this is what I found so far.

  4. tonyzeoli
    Member
    Posted 4 years ago #

    @Alex

    I figured it out. It was my .htaccess file. I had two files in two different directories and it was causing a problem with Apache. I deleted the .htaccess file in both the top level and the "wordpress" folder, then reinstalled the file with mod_rewrite rules intact. That solved the issue. I'm back and running.

  5. ChrisCree
    Member
    Posted 4 years ago #

    Had the same problem with WordTube not being able to detect the player after I upgraded even though my player-licensed.swf file was in the correct folder. Here is how I got it to work.

    On the Settings --> WordTube --> General Options tab I changed the setting for Path to JW Media Player from the default of

    /home/xxxxxxx/public_html/wp-content/uploads/player.swf

    to

    wp-content/uploads/player-licensed.swf

    and then it worked no problem.

    If you are using the unlicensed (free) JW Player then you should just change that text box setting to

    wp-content/uploads/player.swf

    and, all else being equal, I'm thinking it will start working for you.

  6. Theiceman6
    Member
    Posted 4 years ago #

    ChrisCree Thank you :D

    It worked like a charm :D

  7. Marcus_P
    Member
    Posted 4 years ago #

    @ChrisCree

    Awesome, your hint is working.

    I think I missunderstood Alex as he was asking about the path configuration, sorry for that.

    Lot of thanks ;)

  8. ChrisCree
    Member
    Posted 4 years ago #

    Sometimes just hearing the same thing said in a slightly different way makes the whole thing clearer. ;)

  9. lepensky
    Member
    Posted 4 years ago #

    #berlinflieger, #ChrisCree
    It's work! Thx!!!
    Enjoy in Gotan Project: http://www.video-music.info/gotan-project-la-gloria-video/

  10. autark
    Member
    Posted 4 years ago #

    I am having the same problem Tony was having, can NOT update my path to .swf in Settings --> WordTube --> General Options, no matter what. I do not have the double .htaccess file problem though.

    I am running wordpress locally on my laptop using WAMP (Windows, Apache, MySQL, PHP).

    Every time I try updating that field it just reverts back.

    The odd thing is, it's using a path value that exists only on my live web server, so it copied the setting from somewhere when I copied the files down locally...

    Arg, frustrating.

  11. marangyi
    Member
    Posted 4 years ago #

    @ChrisCree,

    You just became my new BFF!

    Thanks for the clear instructions!

    Ron

  12. DouglasVB
    Member
    Posted 3 years ago #

    @ChrisCree

    That solution worked for me. I'm running my WordPress install in the root directory and still had to do that. Hope it gets fixed for everyone else soon!

    Keep up the good work @Alex.

  13. Yos
    Member
    Posted 3 years ago #

    Sorry for bumping this ticket up but I'm still having these problems. My issue is after a clean installation (so not an update) but still I get the error Get the Flash Player to see the wordTube Media Player.

    I tried al kinds of values for Path to JW Media Player but nothing seems to work. Right now the value is /wp-content/uploads/player.swf.

    By the way, my installation isn't in the root folder too. WordPress is installed in mydomain.com/blog/

    Anyone who knows what to do?

    Thanks in advance!

    Y.

  14. Yos
    Member
    Posted 3 years ago #

    Shame on me...

    Forgot the <?php wp_head(); ?>.

    That solved it.

  15. hatnaa
    Member
    Posted 3 years ago #

    Please use this format.

    http://i48.tinypic.com/2hx6fe0.jpg

  16. Impact9
    Member
    Posted 3 years ago #

    I don't quite get this. I'm using the current stable release of WordPress and the current plugin of Wordtube using the wordpress plugin installer. I've edited the general settings like a dozen times as suggested and moved my swf files around to different directories. I just can't get it to work, well I can't get the plugin settings page to say it found my player. I don't know if my player.swf is just buried too far down into my website directory tree or what is going on.

    World someone take a look at my settings please.

    http://i34.tinypic.com/4g5hj8.jpg

    Thanks all!

  17. Derschmidt
    Member
    Posted 3 years ago #

    I find myself also in the situation that everything worked until updating to Version 2.3.1
    in my WP index.php template i donĀ“t find any <HEAD> </HEAD> tags to write <?php wp_head(); ?>
    Can anyone give me at least a hint to find this...

  18. toasterboy1
    Member
    Posted 3 years ago #

    I have a similar but probably different problem. I run 2 blogs but only one wordpress install. As outlined here
    It allows me to update both sites at the same time. All my plugins are centrally located and can be used by both blogs. My player.swf and yt.swf are centrally shared as well. The only plugin with problems is wordtube and only one where it says "Get the Flash Player to see the wordTube Media Player." The settings for both blogs are the same:
    Path to JW Media Player: wp-content/uploads/player.swf
    Upload folder: wp-contents/uploads

    Site 1:video
    Site 2:video

    DISTRIB_DESCRIPTION="Ubuntu 10.04.1 LTS"
    Wordpress Version 3.0.1
    NextGEN Gallery Version 1.6.2
    wordTube Version 2.3.1

    In response to <?php wp_head(); ?> it is now in the header.php file.

  19. toasterboy1
    Member
    Posted 3 years ago #

    Got it fixed. Was missing a link to wp-includes on my second site.

  20. tamerimad
    Member
    Posted 3 years ago #

    hello
    for the problem of the wordtube ,,
    i fixed it like in this way , i hope it will help
    i deleted the wordtube 2.3.1
    and i re-installed the word tube 2.2.2 from this link
    and then i upload to the wordpress and activate it
    and every thing worked again
    hope it will help u
    best regards

  21. Kieran McMillan
    Member
    Posted 3 years ago #

    My client upgraded to the latest Wordtube version 2.4.0, when suddenly the video stopped working. I checked the wp-admin plugin page, and saw an error saying the path was incorrect to player.swf. I searched the ftp directory, but couldn't find it, so I downloaded the 2.4.0 plugin, and player.swf was not included. I read this thread, and saw the link to http://wordpress.org/extend/plugins/wordtube/download/ and downloaded 2.3.1 - player.swf was there! So I was able to upload the player.swf to wp-content/uploads and updated the path in the plugin page in wp-admin!

    Problem solved...

  22. bhupi123
    Member
    Posted 3 years ago #

    Hi

    I used the quick fix (lowercase001) and it worked, so tried (ChrisCree), both working.

    Now can someone please tell me how can I display the same thing in my template file. I do not want to use shortcode, I want to use template file to display these videos on my home page in my site.

    Please suggest me something. I will really appreciate your words.

    Thank you for all your discussion and suggestions.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags