WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: wordTube] The Flash player is not detected. (52 posts)

  1. djtls803
    Member
    Posted 4 years ago #

    I have just upgraded to the 2.3.1 wordtube plugin and now I can not get it to work at all. Before I updated the plugin it worked fine. I followed the instructions as listed on the site but I still keep getting the message: The Flash player is not detected. Please recheck if you uploaded it and verify the path in the wordTube settings.

    If anyone knows a fix let me know . Thanks.

    http://wordpress.org/extend/plugins/wordtube/

  2. Alex Rabe
    Member
    Posted 4 years ago #

    What path do you setup in the settings ?

  3. djtls803
    Member
    Posted 4 years ago #

    The instructions just said to put the yt.swf and player.swf file into the wordpress upload folder. Is there something I have to edit in one of the plugins .php files? the files are in the default dir: wp-content/uploads/

  4. Marcus_P
    Member
    Posted 4 years ago #

    Same Problem here too.

    But the error is only shown at the media list under wordtube, where the video files are listed.

    Also I've tried to change the path where the player.swf is located but wordtube won't let me do that and goes back to standard wp-content/uploads folder.

    But if I rename the player.swf in the wp-content/uploads folder I've got also an errormessage at the configuration page from wordtube, so i do not know what ist causing this errormessage at the media list.

  5. Alex Rabe
    Member
    Posted 4 years ago #

    The path should be wp-content/uploads/player.swf , please verify this setting

  6. tonyzeoli
    Member
    Posted 4 years ago #

    Hi:

    I'm having the same issue.

    Please see hiphopmuseum.org. Player is in center of page. I have playlist id=1 and all my files assigned to that id.

    My path is set correctly. My swfs are in the wp-content/uploads/... folder.

    In the media center, I can play each individual file, but the player is not working on the home page.

    We have a major Hip-Hop Museum event tomorrow night and people are looking at this page right now. Very frustrating. Happened after upgrade.

  7. djtls803
    Member
    Posted 4 years ago #

    `here is my directory listing setup directory picture

  8. Marcus_P
    Member
    Posted 4 years ago #

    @Alex

    ..../wp-content/uploads/

    Was the folder, where the player.swf and the yt.swf is located, but then occures the error message in mediathek/wordtube, but in the configuration I've got no errormessage, so i think the path will be right.

    So I've tried to get the player to another location, but i can't change the folder path in the wordtube configuration.

    So I've done a rollback and put the previous version into my wp, now it's working fine with the new player.swf in the plugin folder.

    Hope the path problem can be fixed, so i can upgrade to the new version.

  9. nimopress
    Member
    Posted 4 years ago #

    i noticed this in the 2.3.0 release when i upgraded 2.2.2 on 3 of my wordpress sites. the media players would not load. couldn't change the folder directories either. thought it was an isolated bug on my theme since all 3 sites were based on the same framework.

    rolled-back to 2.2.2 with no problems. for the record, JWP v5.1 works on wordtube 2.2.2. i know cos' i had uploaded the new player.swf a day before 2.3.0 was released. working JWP 5.1 on wordtube 2.2.2:
    http://nimopress.com/pressed/blog-building-wordpress-means-business/

    i saw the prompts on my wordpress dashboard for 2.3.1 today. glad i checked the forums before upgrading. hopefully, this bug gets sorted out soon. wordtube is a great plugin. from what i noticed, the new UI has some improvements over 2.2.2.

  10. tonyzeoli
    Member
    Posted 4 years ago #

    I'm sure Alex must be working on this, but the downtime is killing me. I wish I would have kept the last version. Anyone want to send me the file? I'd appreciate it. We're supposed to have our video online today for a huge event tomorrow and now I'm screwed.

  11. Alex Rabe
    Member
    Posted 4 years ago #

    A function inside the settings page will always check for the player at several places, it also moves the player.swf to the upload folder (if possible). If this is not working at your side, two questions :

    1.What path is set when you call the settings page ?
    2.Have you a changed directory sturcture, compared to the classic wp-content/uploads ?

  12. Alex Rabe
    Member
    Posted 4 years ago #

    BTW : here are all versions of wordtube http://wordpress.org/extend/plugins/wordtube/download/

  13. ykruger1
    Member
    Posted 4 years ago #

    Thanks! I'll roll back to the previous version and wait untill this is solved.

  14. ykruger1
    Member
    Posted 4 years ago #

    eeehm, I rolled back to previous version, but now the same problem occurs!!! Please help, hope this is solved soon.

  15. Marcus_P
    Member
    Posted 4 years ago #

    @Alex
    1.What path is set when you call the settings page ?
    Erm, you mean this?
    /wp-admin/options-general.php?page=wordtube-options

    2.Have you a changed directory sturcture, compared to the classic wp-content/uploads ?

    This ist the location at my webspace ^^
    /homepages/11/dxxxxxxx/htdocs/wordpress/wp-content/uploads/player.swf
    /homepages/11/dxxxxxxx/htdocs/wordpress/wp-content/uploads/yt.swf

    I think it's the classic folder structure, or not?

    @ykruger1
    Have you tried to put the player.swf and the yt.swf in the WordTube pluginfolder (e.g. /wp-content/plugins/wordtube)?

  16. ykruger1
    Member
    Posted 4 years ago #

    @Marcus_P Thanks for the tip! I have tried it but it makes no difference...

    @Alex & Marcus_P: I have inspected the page and I see that the address of the player is not set right. It says:

    http://www.fitin90dagen.nl/wordpress2//home/ykruger/public_html/wordpress2/wp-content/uploads/player.swf

    You see? The address of the player is not put together properly.... How does this happen and where can I change this sincs I cannot change the address in the options panel. Hope this is a step to the solution.

    Yvon

  17. ykruger1
    Member
    Posted 4 years ago #

    Found it! I now managed to actually change the address in the optionspanel and cut off the first part (//home... etc). It works now.

  18. Alex Rabe
    Member
    Posted 4 years ago #

    Ok, I will update the description. Indeed it should only the relative path

  19. berlinflieger
    Member
    Posted 4 years ago #

    @ykruger1
    Please tell us how u "managed to actually change the address in the options panel"... Since many of us we're not able to change it!

    @alexrabe
    Thanx for your great work on the plugin. I don't mind this first bug at all :) Keep it up!

  20. tonyzeoli
    Member
    Posted 4 years ago #

    This is the path to my settings page:

    http://www.hiphopmuseum.org/wordpress/wp-admin/options-general.php?page=wordtube-options

    This is the path to player:

    http://www.hiphopmuseum.org/wordpress/wp-content/uploads/player.swf

    And it says this in the options panel:

    Path to the Jw Player: wp-content/uploads/player.swf

    This is the path to uploaded content files:

    http://www.hiphopmuseum.org/wordpress/wp-content/uploads/2010/04/foo.flv

    I put foo.flv file in the main upload directory, still nothing.

  21. berlinflieger
    Member
    Posted 4 years ago #

    Path to JW Media Player: /wp-content/uploads/player.swf Fixed it!

  22. tonyzeoli
    Member
    Posted 4 years ago #

    Not for me.

    @alex...by the way, the player is playing the files uploaded in the files panel.

    It's the main player that still has the X over the play icon.

    I can't get that to work.

  23. atrebla
    Member
    Posted 4 years ago #

    Changing the path didn't do the trick for me, but by inspecting the source of the page, I noticed that the swfobject.embedSWF was pointing to the wordtube plugin directory
    swfobject.embedSWF("http://[xxx]/wp-content/plugins/wordtube/player.swf"

    I dropped the player in wp-content/plugins/wordtube and it works beautifully (player v.5 licensed)

  24. tonyzeoli
    Member
    Posted 4 years ago #

    I uninstalled the plugin, which dropped all the tables and reinstalled. Now uploading all files again. I have player.swf in both the uploads folder and wordtube folder.

    My single player is working, but my playlist player is not.

    Very frustrating.

    Tony

  25. Alex Rabe
    Member
    Posted 4 years ago #

    @atreba If you dropped the player in the plugin folder it will be ereased during the next upgrade.

  26. atrebla
    Member
    Posted 4 years ago #

    Yes, I'm aware of that. But I couldn't take the downtime and just did that as a temporary measure.

    Thanks for the reminder, though =)

  27. Alex Rabe
    Member
    Posted 4 years ago #

    @tonyzeoli

    What have you setup In your general settings for :
    WordPress address (URL) & Blog address (URL)

    As I can see from your links yu have placed wordpress in the subfolder :

    http://www.hiphopmuseum.org/wordpress/

    , so I maybe take the wrong URL (I used siteurl and not home)

  28. tonyzeoli
    Member
    Posted 4 years ago #

    Yes, I have put WordPress in a sub folder and moved the index.php file to the main directory.

    This is recommended, so you don't mix all your WordPress files with other files in the main directory.

    Many people are doing this now.

    I cannot change the path. Can you tell me how to change it until the next upgrade?

    Can you direct the plugin to use blogpath OR sitepath somehow?

  29. ykruger1
    Member
    Posted 4 years ago #

    Hi all, this is what worked for me:

    In firefox I use an add-in named firebug. When you install it you get the opportunity to look at the coding of the page you see in Firefox.

    There you can easily find the line that points to your wordtube-player. Here I saw that the link was not correct.

    Apparantly the settings are different for everybody, so I suggest that you look in your own file to see wordtube is looking for the player.

    When I first tried to change the address I did not change the prefix (something like //home.../ in my case), but I only tried to change the last part of the address. That did not work.

    So I suggest:
    - first see if you can strip the first part of the path in the settings and just keep this: /wp-content/plugins/wordtube/player.swf

    - If that does not work, then check with firebug what your wordtube is trying to do...

    Hope this explanation helps!

    Yvon

  30. lowercase001
    Member
    Posted 4 years ago #

    Hey Alex,

    A simple explanation of what is happening to everyone.

    This path when upgrading problem exists for everyone who does NOT run wordpress in the root directory.

    I run wordpress in http://www.sitename.com/new

    So the upgraded plugin can't find the player.swf and does not let me manually change the admin page to put in my full url to the JW PLayer.

    Easy.

    Any ideas on how to fix this? Why no matter what I enter via the wordtube settings 'Path to JW Media Player' field it changes straight back to '/player.swf'?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags