WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [Plugin: WordPress.com Stats] Stats Graph missing after update (21 posts)

  1. Thenook
    Member
    Posted 4 years ago #

    Hi, I ran through updating my WP software and stats using the update automatically links, now the graph for the stats is not working. Just shows a blank white box instead. Any recommendations would be appreciated.

    http://wordpress.org/extend/plugins/stats/

  2. Andy Skelton
    Member
    Posted 4 years ago #

    This often happens because the Flash file was not properly uploaded. Please download the plugin and copy the files to you server.

  3. yourlancasterhome
    Member
    Posted 4 years ago #

    I just installed wordpress.com stats this morning and it's picking up the data fine but the graph won't display. Updated WP to 2.9.1 and flash player 10 (again) just in case - still won't display. Thoughts? Thnks

  4. Thenook
    Member
    Posted 4 years ago #

    I did the manual upload, same problem. However the graph works fine from my other sites, just not this one.

  5. rollinsr
    Member
    Posted 4 years ago #

    Same problem. Blog hosted by my own server. Updated to WP 2.9.1 and WordPress.com stats 1.6.1. Now no stats graphs will display. The data is there.
    Reinstalled WordPress stats 1.6.1 plugin. Still does not display graphs.
    Used both Firefox 3.5.7 (with Adobe flash player 10) and IE 8 (with Adobe flash player 9) and neither display stats graph.
    Searched forums and found several reports of similar behavior but no fix suggested worked for me.

    I can see my blog stats (including graphs) by logging in to Worpress.com.

    It seems this problem has been floating around for over six months so I assume there must be a fix...I just cannot seem to find it.

    Any help would be appreciated.

    Thanks

  6. Andy Skelton
    Member
    Posted 4 years ago #

    I have seen this problem caused by failures to serve the flash file at wp-content/plugins/stats/open-flash-chart.swf. Try loading that in your browser. If it doesn't load, either the file
    isn't installed properly or your server is configured not to serve it.

  7. rollinsr
    Member
    Posted 4 years ago #

    Thanks andy!

    It was a problem with my server. My apache httpd server ver. 2.2.9 does not like the .htaccess file included in the new version of stats. I removed that file and it works fine now!

    I did notice the .htaccess file was in the new update but then did not try removing it to fix things....I tried almost everything else.

    Perhaps this will help others that are having this problem.

  8. Andy Skelton
    Member
    Posted 4 years ago #

    rollinsr: I'm glad to hear you fixed the problem but unsettled by the new mystery of what's wrong with the .htaccess file. I haven't run into that problem myself. If you have the time and inclination to find out why Apache doesn't like it, I'd be very grateful to know.

  9. billnanson
    Member
    Posted 4 years ago #

    I have the same issue since upgrade - no graphs, but lists are fine. It also haThere is a server dimension:
    - Firefox/home PC/ADSL network - no graphs
    - IE7 laptop/home ADSL - no graphs
    - IE7 (same)laptop/company network - no graphs on dashboard but graphs on ststs page... (!!)

    All were replete with graphs before last update.
    Bill

  10. rollinsr
    Member
    Posted 4 years ago #

    andy: There is nothing wrong with the .htaccess file. Rather, it is that some server admin (such as myself on my own server) have very tight security on the httpd server (apache) which provides public access to directories on the server.

    In order for apache to read .htaccess files in a given directory, that directory must have the AllowOverride directive enabled. This sort of issue is discussed here (under "Fixing Other Issues") in connection with using WordPress permalinks.

    The AllowOverride directive is set in the httpd.conf configuration file for the apache httpd.
    I had used the restrictive:AllowOverride FileInfo to allow WordPress to use a .htaccess file to format permalinks for my blog, but that is not sufficiently permissive to allow the Allow from All directive that is in the .htaccess file included in stats 1.6.1 update. Hence apache stopped upon reading the .htaccess file and did not even try to open the .swf file. I could fix this without getting access to the httpd configuration file by simply removing the .htaccess file from the stats plugin directory. (The Allow from All directive was already set for my blog directory anyway in the httpd.conf file).

    To make sure that this explanation is correct, I went into the httpd.conf file and opened up the blog directory to any .htaccess file by replacing AllowOverride FileInfo with AllowOverride All and restarted the httpd server. Now my blog displays the stats with graphs using the original update 1.6.1 (with the .htaccess file) as distributed. This "fix" would not be available to the general user without admin privileges for the httpd server. I left my server set up this way so that the next update should work with no trouble.

    Sorry about the length of my response, but I wanted to be as clear as possible.

  11. Andy Skelton
    Member
    Posted 4 years ago #

    Thank you for the verbose response. When I added the .htaccess I did not know that Apache could be configured such that my directive would cause the file to become inaccessible. Do you know a way to rewrite the Stats .htaccess file to avoid this conflict?

    For context: I added the .htaccess file in response to a user whose charts would not appear because his wp-content directory included a .htaccess file forbidding access to all files.

  12. rollinsr
    Member
    Posted 4 years ago #

    andy: As I understand things, Apache will not read .htaccess files in a directory unless some AllowOverride directive is enabled for that directory. I tried the following AllowOverride settings for my blog directory with the results noted:

    AllowOverride None
    Your stats plugin works fine. [I guess this is because Apache does not even look for .htaccess files at all, so your .htaccess file is simply ignored. (Most WordPress servers would not be set this way because fancy permalinks probably would not work.)]

    AllowOverride FileInfo (so WordPress permalinks work)
    Your stats plugin does NOT work UNLESS I remove the .htaccess file. [I guess this is because Apache now reads the file and finds the Allow statement is not allowed to be overridden and reports an error AND apparently denies all access to *.swf files in the stats directory.]

    AllowOverride FileInfo Limit
    or
    AllowOverride All
    Your stats plugin works fine in either case.

    I believe one of the latter Apache server configurations is NECESSARY in order for your stats plugin to work as is. I don't think it is possible to fix this from within the .htaccess file itself. What you need is a conditional statement to check the AllowOverride directive status before the Allow statement and I don't think such conditional statements exist.

    Of course, your .htaccess worked to override the users .htaccess file in the directory above because the Apache configuration had to have been set as indicated above or his .htaccess file would not have worked. But your fix broke it for others because of the (strange) way Apache behaves when it finds an unallowed statement in a .htaccess file.

  13. Thenook
    Member
    Posted 4 years ago #

    Deleted that htaccess file, works fine , thanks a lot!

  14. peppies
    Member
    Posted 4 years ago #

    Greetings,

    I installed a stats plug-in a few days ago. I am receiving statistics, referrals and stuff like that, but my stats chart is completely blank.

    How do I get it working so I can see the line graphs?

    My stats plugin info:
    WordPress.com Stats
    WordPress Version 2.9.1 | Version 1.6.1 | By Andy Skelton

    Also, I noticed Andy mentioned checking out this file:
    wp-content/plugins/stats/open-flash-chart.swf

    I am confused. The installation instructions say to upload only "stats.php" to the appropriate directory. Are we supposed to upload that entire folder or just that one php file??? (http://wordpress.org/extend/plugins/stats/installation/)

    Thank you

  15. peppies
    Member
    Posted 4 years ago #

    Yep, that was it.

    Andy, I notice on your product page that 40 people say this plugin works and 28 say it's broken. I am willing to bet that many people assume it's broken because of the confusing installation instructions and they never bother take a second look at it. I would recommend revising the instructions for installing this plugin.

    Otherwise this seems like a good feature.

    Regards

  16. Andy Skelton
    Member
    Posted 4 years ago #

    peppies: thanks for spotting that! I've uploaded new instructions. They will show up there soon.

  17. bigdaddywhale
    Member
    Posted 4 years ago #

    Deleted that htaccess file, it now works fine.

  18. zordrak
    Member
    Posted 4 years ago #

    Just to echo from above, deleting the .htaccess is unnecessary, you just need to tell Apache that the file is allowed to override limit directives:

    AllowOverride Limit

    Which, if you are using permalinks would be:

    AllowOverride FileInfo Limit

  19. MBoudet
    Member
    Posted 4 years ago #

    Deleting the .htaccess file worked for me! Thanks!

  20. kingkong954
    Member
    Posted 4 years ago #

    ...deleting worked for me too.

  21. ozzywood
    Member
    Posted 4 years ago #

    Hi Andy,

    I've just changed over from an Australian host to Media Temple.

    When reinstalling Stats, I cannot find the blog account my existing stats were sitting under.

    I have two WordPress.com accounts, each with a series of self-hosted blogs (most of them non existing but I don't know how to clean up this mess).

    I have just spent an hour going through each of them, deactivating and re-activating Stats so it prompts me to enter the API key to replace the blog account.

    Every single one of them returns ZERO stats.

    I have gone through this process successfully a few times over the past couple of years but for some reason this time it won't work.

    I've read through the forum q&a but from the stuff I understand, there's nothing I haven't tried.

    I'm frustrated as my blog has been experiencing some great traffic increase and I like monitoring it through Stats!

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags