WordPress.org

Ready to get started?Download WordPress

Forums

WordPress.com Stats
Just flat out quit working (17 posts)

  1. S.W.Anderson
    Member
    Posted 3 years ago #

    My blog was hacked just before the 3.1 upgrade. I had to move it to a different subdomain, changed the WP_ prefix in the DB, imported past posts, categories, tags, etc. I changed all passwords and installed the BulletProof WordPress plugin. I have a redirect from my former subdomain to my new one. Somewhere in all this, WordPress Stats quit working.

    I went to the WordPress Forums and tried some things that apparently worked for others in the past when this plugin quit. I've tried everything I can think of, including scouring my .htaccess files to make sure Auttomatic isn't being blocked. I uninstalled and reinstalled Wordress Stats. I disabled all other plugins, then re-enabled them one by one. My key doesn't seem to be an issue. I've checked error logs to see if I can spot something. All to no avail.

    The LBAK and WP Easy Stats plugins both work, but I like WordPress.com Stats best. I hope something can be done by the author or some information about what more to check can be made available.

  2. agreda
    Member
    Posted 3 years ago #

    Perhaps the issue is unrelated to the hack. After upgrading our multisite install to 3.1, we too lost Stats functionality.

    Too clarify, on sites where WP.com Stats had already been activated, the stats do display, and the new Shortlink menu works in the Admin Bar. The Stats configuration panel, however, is inaccessible. Clicking the WordPress.com Stats configuration link in the dashboard redirects to mainsite.com/wp-admin/?c=1 -- regardless of which site is being administered.

    An attempt to activate Stats on another member site results in the same redirection for the configuration link. That site's dashboard shows the message "WordPress.com Stats needs attention: please enter an API key or disable the plugin." with the same bad link.

    So, now we have sub-site bloggers unable to activate Stats, and asking why they don't have the new Shortlink menu. I figured it was just because the needed to activate stats. <sigh>

    We have Akismet network activated with a hardoded API, and it is functioning but also has a configuration link that now redirects to the main dashboard.

    Any feedback is greatly appreciated. Thanks.

  3. agreda
    Member
    Posted 3 years ago #

    Does anyone have any feedback about using the WP Stats plugin with WP 3.1 Multisite?

    Stats display properly via the Site Stats link (/wp-admin/index.php?page=stats), but the config link (/wp-admin/plugins.php?page=wpstats) redirects to the dashboard (/wp-admin/?c=1).

    New members wishing to activate the plugin cannot do so because the admin page cannot be accessed to enter a key.

    We are running the most current version, which indicates 3.1 compatibility. Thanks in advance for any suggestions.

  4. S.W.Anderson
    Member
    Posted 3 years ago #

    Problem solved. It was related to running the Bulletproof Security plugin and not making all the changes recommended on the BPS, AIT Pro support page. The plugin author indicates future versions will make it unnecessary to go into files to make modifications. I got interrupted while doing it and didn't discover until later that I had missed a couple (my bad).

    So, both the security plugin and WordPress Stats are working well now. I hope this will help someone else who's having the same difficulty.

  5. agreda
    Member
    Posted 3 years ago #

    @SW Glad you got it working! We are not using BPS. Did modify WP Stats in any way to get that plugin working? If so, care to share what?

    Does anyone else have any feedback regarding why the WP Stats admin config page might be inaccessible under WP 3.1 MS?

    Thank you!

  6. S.W.Anderson
    Member
    Posted 3 years ago #

    @agreda, the good news is that I had WordPress Stats working again. The bad news is that last night, I got an update of BPS, and since updating, WordPress Stats quit working again. I've done the modfifications of BPS files necessary for a blog in a subdomain, but the Stats plugin still doesn't work. So, I wrote BPS' author, and he's looking into it.

    To answer your question, I did not modify anything in Wordress.com Stats.

  7. agreda
    Member
    Posted 3 years ago #

    So, I've been wondering if anyone might ever provide feedback for the issue I described... and now with this JetPack announcement and the ensuing commentary about what it means for WordPress, I can see how my concerns may never be addressed.

    If WP Stats will no longer work as a standalone plugin under WP Multisite, would someone just say so? If it should, any feedback is greatly appreciated.

    Thanks in advance to anyone who may be able to shed some light on this.

    [stepping off soapbox]

  8. Hollybopp
    Member
    Posted 3 years ago #

    my website's stats also stopped working after the update to wordpress. I really wish they would stop updating wordpress. It is fine the way it is.

    my stats now say " I dont have athority to view these stats" meanwhile two days ago it was fine. (before the update) so if i cant use "wordpress stats" anymore what plugin will work?

  9. Joshua Russak
    Member
    Posted 3 years ago #

    For some strange reason, when I go to Dashbboard>Site Stats it says "Already Installed: You appear to have already installed WordPress. To reinstall please clear your old database tables first." yet I didn't do anything?

    Thoughts?

    -Red

  10. agreda
    Member
    Posted 3 years ago #

    Woah... we have been able to view stats, just couldn't access the config page. Then today, sure enough, we're seeing the same error message (as Hollybopp). Reviewing our wp.com dashboard sheds no light on the subject.

    Can anyone explain what's going on? WP Stats is still available and listed as compatible with 3.1 in the plugin repository. But that is clearly not the case.

    Wouldn't some sort of notification be nice rather than just pulling the carpet out from under our feet! :-\

    [end rant]

  11. Meredith23
    Member
    Posted 3 years ago #

    Anyone have any feedback or solution to the " not authorized to view the stats of this blog." problem yet? This is crazy? help please!

  12. dematrixshow
    Member
    Posted 3 years ago #

    ye same here, it was working fine maybe 2 hours ago i refreshed the page and that was it, no more.

  13. timmberlin71
    Member
    Posted 3 years ago #

    @ Meredith23: I am having the same problem with one of my blogs. However, until this is solved, I found a way to see my stats for this blog.

    When you login at wordpress.com go to My Account / Global Dashboard and then click on Site Stats you should be able to see stats for each of your blogs (there is a drop down menue to switch between your blogs if you have several in the top right corner).

    In my case, I can see the stats for the blog, that according to my blogĀ“s admin page I am not authorized to...

  14. agreda
    Member
    Posted 3 years ago #

    Here's the thing that gets me... wp.com has what seems like randomly attributed one of my self-hosted sites (call it blog x) as my primary blog, with no way to add any other of our wp.org sites. Only wp.com sites can be registered and/or added.

    Site stats are still visible on blog x, but the inaccessible config page issue remains there. Site stats on our blogs a, b, c, y and z all say I don't have rights to view the stats yet I am provided with no way to authorize them.

    [sigh]

  15. esmi
    Theme Diva & Forum Moderator
    Posted 3 years ago #

  16. txauctionsinfo
    Member
    Posted 3 years ago #

    I've run into the same problem with Site Stats and have been messing with it for the last two hours, with no results. I'm also getting the message: Your WordPress.com account, is not authorized to view the stats of this blog. It was working fine earlier today.

    So, does anyone know who to contact to get the problem resolved.

    (Yes, esmi, I read the thread you're posting on all the threads, but it does not provide any information about getting this problem fixed and I currently have no interest in jetpack.)

  17. steyrtal
    Member
    Posted 3 years ago #

    Same here: Since this morning, I can no longer access my site stats (not authorized to view ...).

    But there are more strange things: Something has also messed up my blog layout - the footer has moved off to the right, which affects the whole page and looks very ugly (see here) AND my popular posts wicket does not display at all.

    I am sure it is all connected but cannot see how.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags