WordPress.org

Ready to get started?Download WordPress

Forums

WordPress.com Popular Posts
Popular Posts Output Disappears (40 posts)

  1. jayo
    Member
    Posted 3 years ago #

    The plugin works fine, but the output will disappear sopradically. Like after a full day of it showing up, it disappears, and then will re-appear the next day... it happens almost daily.

    Any idea why its happening anyone? Or has you had the same problem?

  2. jayo
    Member
    Posted 3 years ago #

    Let me know... it seems to be happening every day around 4pm pst, or late afternoon, the popular headlines output disappears and reappears late in the evening at midnight.

  3. Haoxian
    Member
    Posted 3 years ago #

    I just noticed that.

    Why does not anyone look into this plugin and fix it?

  4. nhowarth
    Member
    Posted 3 years ago #

    Popular Posts has been working fine - until today. Now, no posts are being displayed.

  5. jayo
    Member
    Posted 3 years ago #

    Popular Posts has been working fine - until today. Now, no posts are being displayed.

    Same here Nhowarth. Wonder if its some issue with the stats from WordPress. Anyone else have issues?

  6. nhowarth
    Member
    Posted 3 years ago #

    Hi Jayo,

    WordPress stats are showing up OK in the Dashboard - it's very strange.

    Rgds, Nigel

  7. jayo
    Member
    Posted 3 years ago #

    yep, the issue I had before was because I had set the days to one (24 hours), and they'd disappear at the end of the day, because everything reset. I switched it to 7 days and its been fine ever since... until late last night, the output disappeared and hasn't returned.

    I like this plugin and hope we can solve the issue.

  8. jayo
    Member
    Posted 3 years ago #

    Update from the plugin website after I made a comment

    If you look closer, the wordpress servers mailfunction, not the plugin. They wrote a message to your dashboard about some error fixing: “Currently access to stats is broken for some users and we are working on fixing this. Your stats are still being counted and will be visible once we restore access for your account”

    Followed by this response

    Hi,
    the WP Stats Plugin is up and running again but it seems that it doesn’t report the data to your plugin anymore.
    Take a look at http://www.umstellung.info. On the right there is the headline “Beliebteste Beiträge” (Most popular posts).
    Any idea.
    Thank you for this great plugin!
    yours, severin

  9. nhowarth
    Member
    Posted 3 years ago #

    Many thanks jayo

  10. davidryal
    Member
    Posted 3 years ago #

    We've had the same problem starting at the same time <24 hours ago (e.g. http://awesomescreenshot.com/08a9esk1a ). Would love to figure out what is causing this and how to fix.

  11. cwapshere
    Member
    Posted 3 years ago #

    I'm also having a problem. The Popular Posts widget now just displays a heading with nothing listed underneath. I'm not sure when it broke. I did recently update to WP 3.1. I have no messages about problems with my stats and I can see my post stats in my dashboard.

  12. jayo
    Member
    Posted 3 years ago #

    I had noticed that people are having problems with their WordPress.com stats as well. Maybe there's an connection.

  13. editor
    Member
    Posted 3 years ago #

    I've got the same problem. It happened after the troubles at WP-Stats. Now stats are back, but the plugin displays just the heading.

  14. beckhamlkc
    Member
    Posted 3 years ago #

    There are 2 possibilities:

    1. I took a look at the codes of this plugin, seems like the WordPress.com Stats API, stats_get_csv(), which this plugin is calling to, could not be triggered, even using Ben Gillbanks' code (http://wordpress.org/extend/plugins/stats/faq/).

    2. When I logged into my WordPress.com account, which is tied to the blog stats, permission is denied. This is related to the hot topic over the WordPress.com plugin discussions - "Your WordPress.com account is not authorized to view the stats of this blog"

  15. editor
    Member
    Posted 3 years ago #

    I've installed Jetpack. I had some troubles with it because there's a conflict with W3TC. I've deactivated W3TC, activated Jetpack and reactivated W3TC. Now WP Popular Posts works, except for the fact that is not correctly formatting the

      kind of list in the widget. Moreover I had to increase to 2 the magic number to get the 5 popular posts that I wanted. All fixed, but maybe there's some code to clean up, somewhere...
  16. davidryal
    Member
    Posted 3 years ago #

    1. I took a look at the codes of this plugin, seems like the WordPress.com Stats API, stats_get_csv(), which this plugin is calling to, could not be triggered, even using Ben Gillbanks' code (http://wordpress.org/extend/plugins/stats/faq/).

    I saw some other discussion about how JetPack abandons the API for some kind of XMLRPC call to do that communication. If this is true, is it possible they just discontinued API support first for stats (breaking many people's stats), then fixing that, but leaving popular posts broken, possibly because less people use it that way? Is that popular posts plugin working for *anyone* these days?

  17. nhowarth
    Member
    Posted 3 years ago #

    This worked for me:

    1. Install JetPack (doing this this deactivates the WordPress.com Stats plugin).

    2. Delete the WordPress.com Stats plugin.

    WordPress.com Popular Posts now displaying correctly.

    See 'Most Read Articles' in right-hand column at Cyprus Property News

    Cheers, Nigel

  18. davidryal
    Member
    Posted 3 years ago #

    This worked for me:...
    Cheers, Nigel

    this seems to have worked (at least partially) for the *first site* in our 16-site multisite install. Not sure why it isn't bringing pop posts back on subsequent sites...?

    (pattern: each subsequent site connection first gives an xml-rpc error, then works/connects on the second attempt)
    (edit: also sometimes an "verify_secrets_mismatch" errorbefore finally allowing connection)
    (edit2: halfway through, I gave up on activating one by one and network-activated the plugin; all connections from there on our had no errors... ???)
    (edit3/update: featured posts are now showing on some of our sites (craftingagreenworld.com, planetsave.com), not showing on others (cleantechnica.com, inspiredeconomist.com), and partially-showing on yet others (gas2.org). Afaik, nothing could be different among them. So confused.)

    Yay for new flashless-wp-stats interface. Boo for popular posts semi-compaitbility (though based on the partial-weirdness patterns I'm seeing, doesn't seem to hard to fix for someone smarter than I)

  19. jayo
    Member
    Posted 3 years ago #

    yea works for me too now, after adding Jetpack.

  20. davidryal
    Member
    Posted 3 years ago #

    Is now working on some of our 16 sites, but still can't figure out why some would behave differently than others. Next up: messing with magic numbers (1 was always fine, but who knows?)

  21. editor
    Member
    Posted 3 years ago #

    Apparently I cannot delete Wp Stat plugin. I get a blank screen on the action, and I have to go back in the browser action.

  22. davidryal
    Member
    Posted 3 years ago #

    Apparently I cannot delete Wp Stat plugin. I get a blank screen on the action, and I have to go back in the browser action.

    I deleted via FTP, and it worked. Might try that.

  23. editor
    Member
    Posted 3 years ago #

    It worked deleting by FTP, but I need to keep the magic number set at 2, if I want to get the number of popular posts I want.

  24. Ed Fritz
    Member
    Posted 3 years ago #

    I have been following a few threads about Jetpack and WP-stats for a few days
    http://wordpress.org/support/topic/your-wordpresscom-account-is-not-authorized-to-view-the-stats-of-this-blog/page/5
    I thought I could keep on using WP-stats, but after reading this forum discussion, I installed Jetpack as noted. I now have my site stats back, but I still cannot get this plugin to work,(Plugin: WordPress.com Popular Posts). The title is all that displays, and a few very old posts. I have tried a number of combinations but nothing will get the popular post to display. I have emptied out all caches, disengaged W3T ,

    I could use a tip or suggestion on what to do next....thanks

    Widget for popular post is on footer of my site
    http://www.fritzimages.com

  25. frasten
    Member
    Plugin Author

    Posted 3 years ago #

    Hi, I'm the developer of WordPress.com Popular Posts.
    As you can see, everyone has had issues in the last few days.
    Well, sadly it's not my plugin's fault, because wordpress.com API system is now returning completely wrong data.
    Installing Jetpack incredibly fixes for some users (for me too).
    But this could only be a coincidence, because I think they're gradually fixing these issues to every user.
    I've read above about some new XMLRPC call, but there's currently nothing about that in the Stats module of Jetpack.
    So, everyone should try to update to Jetpack, and increase the magic number to at least 2 in my plugin's setting.
    This asks for more records from the wordpress.com API, and currently is necessary, due to some wrong or empty records (I don't know what the hell they're doing with their database!!!).

  26. davidryal
    Member
    Posted 3 years ago #

    @fransten Thanks for the reply!

    It looks like ours has been working over the weekend since installing Jetpack and upping the magic number at the end of last week.

    Mmmmm, ecosystem formation/organization/disruption. Yummy!

  27. Doug Nix
    Member
    Posted 3 years ago #

    All,
    It's worth noting that even WP Stats is having trouble displaying this data. On mt dashboard widget I can see the graph and I can see top searches, but the areas under Top Posts and Most Active are blank. This data is available if I go deeper by clicking View All.

    I think i'll wait to see if wp.com fixes the API before i add jetpack or anything else...

  28. frasten
    Member
    Plugin Author

    Posted 3 years ago #

    You could try to disable/re-enable WP Stats (and reinsert your API key), just in case.

  29. magonzalez987
    Member
    Posted 3 years ago #

    im on wp 3.0.5

    using wordpress.com stats plugin

    few days ago i get this message:

    Your WordPress.com account is not authorized to view the stats of this blog

    then, it got fixed the next day, and i think the day after that, this plugin

    wordpress.com popular post, stopped working. on the widget it only shows the title and not the posts.

    right now stats shows fine, but on UTC time, not time zone of my country.

    i guess if i havent touch anything, then the developer of this plugin need to ask wordpress.com what to change to fix this plugin.

    im not installing jetpack cause i think is a plugin pack that adds wordpress.com stats, which i already have, and a whole bunch of useless features, which i already have on by using other plugins, which i prefer, cause other plugins update faster than wordpress.com.

    so i got no choice but to wait at least 3 weeks for the fix.

    oh i change the magic number to 2, and same problem here.

    stats works fine, just a different time zone, and popular post doesnt show post.

  30. frasten
    Member
    Plugin Author

    Posted 3 years ago #

    I've already contacted WP.com, and I'm waiting for an answer.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic