WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Tweeter
[resolved] 0.8.2 upgrade broke my connection to twitter (2 posts)

  1. cadfile
    Member
    Posted 1 year ago #

    I will say before I start that WordPress Tweeter has worked for me forever so I know it will work on my install.

    I updated to version 0.8.2 today and after the update I decided to change the shortner I was using from Bit.ly to is.gd due to issues some sites have with the bit.ly links.

    I deleted the bit.ly username and api key, switched the shortner, then clicked on update settings.

    Then I got this error showing the plugin setting page(I removed my directory info):

    'Warning: file_get_contents() [function.file-get-contents]: http:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /xxxxx/wp-content/plugins/wordpress-tweeter/wptweeter.php on line 196'

    'Warning: file_get_contents(http://lab.sliceone.com/29308/request-token?oauth_callback=http://www.reviewgeek.net/wp-admin/options-general.php?page=wptweeter.php) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /xxxx/html/wp-content/plugins/wordpress-tweeter/wptweeter.php on line 196'

    'Warning: file_get_contents() [function.file-get-contents]: https:// wrapper is disabled in the server configuration by allow_url_fopen=0 in /xxxxx/wp-content/plugins/wordpress-tweeter/wptweeter.php on line 196'

    'Warning: file_get_contents(https://api.twitter.com/oauth/request_token?) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /xxxxx/html/wp-content/plugins/wordpress-tweeter/wptweeter.php on line 196'

    I am hosted on Media Temple and again before the update the plugin worked fine.

    I tried removing the settings and deactivating/reactivating but still got the same error.

    So I removed the plugin and installed the previous version 0.8.1. The error above went away but when I tried to sign back in to Twitter from the settings page I got the following echoed back on a blank page (I removed the token numbers to display it here):

    'Array ( [oauth_token] => xxxx [oauth_token_secret] => xxxx [user_id] => xxxx [screen_name] => reviewgeek ) 1'

    So I am stuck. Any other steps I can do to fix this. I really don't want to switch to another plugin.

    http://wordpress.org/extend/plugins/wordpress-tweeter/

  2. tech163
    Member
    Plugin Author

    Posted 1 year ago #

    Version 0.8.3 fixes this.

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic