WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
Infinite loop with Foursquare auth (9 posts)

  1. fmalk
    Member
    Posted 2 years ago #

    I'm having trouble setting up Foursquare with WSL.
    Settings are fine, everything is fine up to the point when I give permissions, but when I'm redirected to

    http://www.mydomain.com/wp-content/plugins/wordpress-social-login/authenticate.php?provider=Foursquare

    (after a while it becomes)

    http://www.mydomain.com/wp-content/plugins/wordpress-social-login/authenticate.php?provider=Foursquare&redirect_to_provider=true

    It becomes an infinite loop, and browsers would send me a message that this is happening and stop loading. I can't figure out what is going on.
    I'm using vanilla WordPress 3.3.1 and WSL 1.1.9.

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. Miled
    Member
    Plugin Author

    Posted 2 years ago #

    does it happen with every browser or other providers?

  3. fmalk
    Member
    Posted 2 years ago #

    Yes, it is happening with every browser.
    I just tested Twitter and the infinite loop is also there, although in a "friendly" manner: I'm sent over and over again to the "ask for permission" page.
    Any ideas?

  4. Miled
    Member
    Plugin Author

    Posted 2 years ago #

    to be honest, i have no clue..

    i'll try to look into it and hopefully come to a solution soon

  5. fmalk
    Member
    Posted 2 years ago #

    Were you able to replicate it?
    Was it working on another version of wordpress? i'm not exactly locked on 3.3.1...

  6. Miled
    Member
    Plugin Author

    Posted 2 years ago #

    most likely this is not related to the wp version but to the server settings... and as far i know it should work on any 3.*, myself im using the 3.3.1 for the tests and development

  7. fmalk
    Member
    Posted 2 years ago #

    Ok, thanks, I'll do my best to debug it and see what I can find.
    If I find anything, I'll post it here.

  8. o0_NaGa_0o
    Member
    Posted 1 year ago #

    REGISTER_GLOBALS must be set to off in the server config to fix this issue.

  9. Janar Jürisson
    Member
    Posted 1 year ago #

    Yes- only problem was "REGISTER_GLOBALS" php flag. After that this problem went away. Waisted hours on it, debugging, trying. Finally it simply works.

    An Idea maybe- add some kind of notice on top of admin screen when globals are on. Maybe it could save someones time in future.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic