WordPress.org

Ready to get started?Download WordPress

Forums

WordPress Social Login
Facebook Login Problem &redirect_to_provider=true#_=_ (3 posts)

  1. ivnus
    Member
    Posted 2 years ago #

    When login with Facebook, I get the popup login, login with facebook account, then it loads the frame to this page and sits there:

    example.com/wp-content/plugins/wordpress-social-login/authenticate.php?provider=Facebook&redirect_to_provider=true#_=_

    Is there something wrong here with the #_=_? I've run diagnostics...all is OK.

    Thanks for the great plugin!!! I appreciate your help on this.

    http://wordpress.org/extend/plugins/wordpress-social-login/

  2. ivnus
    Member
    Posted 2 years ago #

    It seems to be logging into facebook ok....but its the redirect to wordpress afterwards that is the problem.

    I'm running nginx, is there some kind of redirect that I need to do for the Facebook Hybridauth to work?

    Read somewhere about the CURLOPT_SSL_VERIFYPEER => false being set in the base-facebook.php.

  3. Anant
    Member
    Posted 1 year ago #

    I have the same issue. On successful return from facebook popup window is not closing..

    After debug found that it stuck on below line of authenticate.php

    window.opener.wsl_wordpress_social_login({
    	'action'   : 'wordpress_social_login',
    	'provider' : '<?php echo $provider ?>'
    });
    
    window.close();

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic