WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Title rewrite not working (14 posts)

  1. darknailblue
    Member
    Posted 3 years ago #

    For me the title tags are not rewriting at all. Everything else seems to be okay. Is there something I might have mis-configured??

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Could you tell me what your header.php has inbetween <title> and </title> ?

  3. cichy
    Member
    Posted 3 years ago #

    I have exactly the same problem.

    Inbetween <title> and </title> in my header.php I have this:

    <title><?php if (is_home () ) { bloginfo('name'); echo " - "; bloginfo('description');
    } elseif (is_category() ) {single_cat_title(); echo " - "; bloginfo('name');
    } elseif (is_single() || is_page() ) {single_post_title(); echo " - "; bloginfo('name');
    } elseif (is_search() ) {bloginfo('name'); echo " search results: "; echo wp_specialchars($s);
    } else { wp_title('',true); }?></title>

    I know that you wrote that header.php should contain reference to wp_title(''), but I am not sure what exactly should I put there. I've entered
    <?php wp_title(''); ?> somewhere inbetween <head> and </head> but it does not work. Sorry I am not much of the coder. Could you please help me out? Thank you.

  4. cichy
    Member
    Posted 3 years ago #

    Ok found the solution :) I have just put this <?php wp_title(''); ?> inbetween <title> and </title>. As I said I am not a coder at all :).

    Thanks for the great plugin :)

  5. darknailblue
    Member
    Posted 3 years ago #

    For me I am using Thematic as a theme. How can I accomplish this using Thematic??

    ~C

  6. cichy
    Member
    Posted 3 years ago #

    ok this is just a guess. I have not checked it:

    from the header.php try to remove this:

    `// Creating the doc title
    thematic_doctitle();`

    and this:

    `// Creating the description
    thematic_show_description();`

    and add this:

    <title><?php wp_title(''); ?></title>

    right above the "</head>" and below the "?>"

    if this will not work try to add wp_title(''); right above the "?>"

    good luck :)

  7. darknailblue
    Member
    Posted 3 years ago #

    I figured out how to do this properly

    function test_doctitle() {
    	return wp_title('', 0);
    }
    add_filter('thematic_doctitle','test_doctitle');

    And that's All Folks!!!!!

  8. Cipri Palamariu
    Member
    Posted 3 years ago #

    The plugin doesn't seem to work for me. It does not rewrite de description and the keywords of my blog. I'm using WordPress 3.0.1 with multisite enabled, and inbetween <title> and </title> in my header.php I have this:

    <title><?php if(is_single()){	single_post_title();echo ' - ';bloginfo('name');}elseif(is_home()||is_front_page()){bloginfo('name');istudio_page_number();}elseif(is_page()){single_post_title(''); echo ' - ';bloginfo('name');}elseif(is_search()){printf( __('Search results for "%s"','iStudio'),esc_html($s));istudio_page_number();echo ' - '; bloginfo('name');}elseif(is_404()){_e('Error 404 - Not Found','iStudio');echo ' - ';bloginfo('name');}else{wp_title('');echo ' - ';bloginfo('name');istudio_page_number();}?></title>

    I must say that I'm a newbie, and there might be a simple fix, but I can't find it.

  9. Cipri Palamariu
    Member
    Posted 3 years ago #

    I changed to <title><?php wp_title(''); ?></title> and it's the same.

  10. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    @darknailblue: thanks for the fix, I've included this to be in 0.1.5.

    @Cipri: have you been able to solve the problem?

  11. invasive
    Member
    Posted 3 years ago #

    One thing I discovered that is important: you must put

    <?php wp_head(); ?>

    before the closing </head> tag. That allows the plugin to hook in. Otherwise, you will not see your meta description/keywords tags!

    Bill

  12. welshhuw
    Member
    Posted 3 years ago #

    Im having a similar issue too.

    This is what Im getting in my homepage title:

    South Wales Web Design - Inspired WorxSITE TITLE TAGLINE

    Why is the SITE NAME and TAGLINE being added to the end?

    Thanks

  13. irvitrad
    Member
    Posted 3 years ago #

    I encounter the same problem as welshhuw
    Site name and tagline are added to the end of the title
    Would be nice to get this fixed, oherwise I have to use All-in-one-seo again, but I prefer this plugin

  14. welshhuw
    Member
    Posted 3 years ago #

    This is getting silly now... Anyone help me out with this great plugin??

    Looks like ill have to resort back to All in one :(

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic