WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[Plugin: WordPress SEO] sitemap.xml won't build (5 posts)

  1. passiveincomeblog
    Member
    Posted 3 years ago #

    I installed SEO plugin. The dashboard is happy with the path and URL of my site map. They are in the public_html directory. Both files (the xml file and the gz) are new and file size is 0. When I hit the (re)build xml sitemap nothing happens. I still do not have a sitemap. Can anyone please help me with this. It's driving me insane!!!

  2. pxlar8
    Member
    Posted 3 years ago #

    I had a similar issue on a multisite install. I found a workaround that worked in my case: if you update any page and republish it, the sitemap gets built then. Not sure if it'll work for you, but might be worth a try.

  3. Andy Beard
    Member
    Posted 3 years ago #

    Even worse - the files are created even if you have sitemap switched off.

    An incorrect sitemap can have a negative effect on crawling.

    Due to this removing plugin from live sites

  4. Andy Beard
    Member
    Posted 3 years ago #

    Version 1.3 still creates zero byte sitemaps in the root directory even when switched off.

  5. passiveincomeblog
    Member
    Posted 3 years ago #

    Thanks for the plan plxlar8. As soon as I published a post the sitemap built. The test button and the mauual (re)build button does not work. I got an email from Joost. They are tweeking the code and will do an upgrade soon. The plugin is really great, but I just find the support and accompanying documentation really bad. It's designed for techies I think, and if you are a novice or beginner like me it's quite something to get help.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic