WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] [Plugin: WordPress SEO] How to make descriptions show? (9 posts)

  1. mattmikulla
    Member
    Posted 3 years ago #

    How do you get custom meta descriptions entered in the wordpress seo plugin to show?

    Do you place a blank meta descripion tag in the header? Or should the plugin already create it?

    Yes, I have php wp_title(''); between title tags in my header so titles are working fine.

    Is there documentation I am missing?

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Hi Matt,

    the meta descriptions will usually show quite a bit below the title, depending on your theme. The plugin is not always able to determine a description, it doesn't auto generate one and when it's empty, it doesn't display at all, so make sure that the plugin can actually generate a description for that page / post / whatever it is.

    Cheers
    Joost

  3. rlmckenney
    Member
    Posted 3 years ago #

    I have %%excerpt%% set for the meta description but after upgrading to v0.1.5 it produces <meta name="description" content=""> for older posts when I edited them unless I manually created an excerpt each posts.

    Creating new posts seems ok, but the Snippet Preview is broken. For example, I am creating a new post titled: Why you should us a home stager.

    The snippet Preview displays the title as:
    Why you should use a home stager | Suzanne Desrochers | Why you should use a home stager | Suzanne Desrochers | Why you should use a home stager | Suzanne Desrochers | Ottawa Real Estate News

    It should display:
    Why you should use a home stager | Suzanne Desrochers | Ottawa Real Estate News

    The SEO Title section directly below the Snippet Preview is also messed up.

    Is there something I missed when I updated the pluggin?

    Cheers, RLM.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Possibly... Did you delete the plugin and upload the entire new folder?

  5. rlmckenney
    Member
    Posted 3 years ago #

    No. I simply copied the new files in to the same folder. Then deactivated and reactivated it.

    Should I rip it all out and reinstall it?

  6. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Yes, please do.

  7. rlmckenney
    Member
    Posted 3 years ago #

    So, I completely deleted the plugin files and reinstalled v0.1.7

    Now the main Dashboard is broken:

    Fatal error: Call to undefined function is_network_admin() in /home/suzanned/public_html/wp-content/plugins/wordpress-seo/admin/yst_plugin_tools.php on line 356

  8. mattmikulla
    Member
    Posted 3 years ago #

    I deactivated and removed the plugin completely. Then dragged the new version of the plugin to the plugin directory. My wp-admin page is now blank.

    It's definitely breaking my dashboard.

  9. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah this bug was fixed straight after in 0.1.7.1 :) Sorry about that!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic