WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] [Plugin: WordPress SEO] ERROR: sitemap is not a valid feed template. (26 posts)

  1. thepcsamurai
    Member
    Posted 3 years ago #

    Hi. I just installed version 0.1.4 of WordPress SEO and i cant seem to generate a proper XML sitemap. I've deleted all of my exciting sitemap but when i access domain.com/sitemap.xml i get ERROR: sitemap is not a valid feed template. error. anybody getting the same problem?

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    That's weird, could you add your domain URL so I can check it out?

  3. windycitynews
    Member
    Posted 3 years ago #

    Same issue here.

    I will leave the "ERROR: sitemap is not a valid feed template." live so you can take a look at it.

    gnom [dot] es / sitemap.xml

    Thanks.
    James

  4. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm ok that's weird. However, version 0.4, due later this week I think, has a complete new way of handling XML Sitemaps, once that's out please re-test.

  5. jelmer_bb
    Member
    Posted 3 years ago #

    Hi Joost, how is the new version coming along? Have the same problem here. Admin shows the sitemap is creating successfully, but when browsing to http://jelmerdejong.com/sitemap.xml I get an error message:

    "ERROR: sitemap is not a valid feed template."

  6. edelen
    Member
    Posted 3 years ago #

    You may be able to fix this by the following:

    1. Deactivate and delete any installed XML sitemap-building plugin (other than the Yoast plugin).

    2. Deactivate the Yoast plugin.

    3. Delete existing XML sitemap files, both normal and GZIPed.

    4. Reactivate the Yoast plugin.

    5. Use the Yoast plugin to create the XML sitemap.

    The sitemap should now create normally and the error should go away.

    I initially had this same problem because the Google XML sitemaps plugin was installed. Even deactivating it did not work. Following the procedure above corrected the problem.

  7. jelmer_bb
    Member
    Posted 3 years ago #

    Thanks for your reply edelen, unfortunatelly it did not help me. I use a clean WP install and the Yoast plugin is the only SEO / XML builder. Also after deactivating and reactivating and than rebuilding http://jelmerdejong.com/sitemap.xml/ still shows the error.

    Maybe there is something wrong with the redirect (trailing / ?)

  8. edelen
    Member
    Posted 3 years ago #

    My sitemap has no trailing slash. I don't have the forced trailing slash enabled in the plugin because all my pages end in .html.

    Always delete the old sitemap files, too, before you attempt a rebuild.

    Also, did you rebuild your permalinks? All you need to do there is just resave your existing config.

  9. jelmer_bb
    Member
    Posted 3 years ago #

    I don't have forced trailing slash enabled as well, but somehow there is a redirect from http://jelmerdejong.com/sitemap.xml.gz to http://jelmerdejong.com/sitemap.xml.gz/ and same for the .xml

    Also did the rebuild permalinks - no success so far.

    Any other ideas? I can't find the sitemap.xml in the root dir, where should I look? Think there is some redirect mistake or file don't actually create itself.

  10. edelen
    Member
    Posted 3 years ago #

    Yes, you need to create a blank file with that name (and also .gz) and add them, both writable through CHMOD settings, to the same directory that contains the guts of your WordPress installation.

  11. jelmer_bb
    Member
    Posted 3 years ago #

    It gets even stranger. I created the files myself and made them writeable using CHMOD. But after rebuilding, they get delete (I assume by the plugin) and not newly created..

  12. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    This has changed with 0.4, the complete functionality no longer uses static files so all these bugs are gone :)

  13. jelmer_bb
    Member
    Posted 3 years ago #

    0.4 and also after upgrading to 0.4.1 which generates the sitemap_index.xml still the same error. Also after completely deleting the plugin and reinstalling. Maybe its my hosting or another setting.

  14. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Are you running W3TC with this feature on?

    "Skip 404 error handling by WordPress for static files"

    If so, go into your htaccess, find this line:

    # BEGIN W3TC Skip 404 error handling by WordPress for static files

    and below that, remove xml from the list of file extensions.

  15. jelmer_bb
    Member
    Posted 3 years ago #

    I have the cache 404 pages checked indeed (using W3TC), only don't have the mentioned line in my htaccess.

  16. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    No the other one, this one is in the browser cache settings.

  17. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    On that form you can add exceptions, if you add this one:

    sitemap(_index)?\.xml

    it should work.

  18. jelmer_bb
    Member
    Posted 3 years ago #

    Yup, now I got a normal 404 instead of the invalid feed error: http://jelmerdejong.com/sitemap_index.xml

  19. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Hmm that's freaking weird. Could you save settings on the XML sitemaps page one more time?

  20. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Ah wait and now WP isn't serving the error, you should either disable that feature OR add the exception mentioned above.

  21. jelmer_bb
    Member
    Posted 3 years ago #

    Exception added, now the feed error is back. Resave of sitemap did not help. http://jelmerdejong.com/sitemap_index.xml

  22. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Any chance of giving me admin access so i can check it out?

  23. jelmer_bb
    Member
    Posted 3 years ago #

    what is your email address?

  24. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    joost at my domain.

  25. jelmer_bb
    Member
    Posted 3 years ago #

    Turns out my problems was caused by the theme I'm using, that has a feed rewrite rule active. The latest post of @yoast helped me to fix this: http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin

    I removed the redirect code from the theme file and disabled the rss rewrite in the themes admin menu.

  26. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Cool.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic