WordPress.org

Ready to get started?Download WordPress

Forums

[Plugin: WordPress SEO by Yoast] XML Sitemap missing (42 posts)

  1. niccolo_tapparo
    Member
    Posted 3 years ago #

    Hi,
    I have a problem with WordPress SEO: the sitemap has disappeared! It should be here: sitemap_index.xml, but I receive a page not found. Sitemap functionality is active and WordPress SEO is 4.2. I deactivated and reactivated WordPress SEO, nothing. Then I tryed to deactivate the other plugins, but nothing again. Could someone help me? It has always worked well since I installed WordPress SEO!

  2. Vakantie Ameland
    Member
    Posted 3 years ago #

    Same here, now using old Google Sitemap XML plugin which works

  3. BBilal
    Member
    Posted 3 years ago #

    make sure that you use http://sitename.com/sitemap_inde.xml but not http://www.sitename.com/sitemap_inde.xml

    Also, what's your site link please?

  4. Vakantie Ameland
    Member
    Posted 3 years ago #

  5. Pierre_
    Member
    Posted 3 years ago #

    Hi,

    I am new to wordpress and of course with Yoast WordPress SEO.
    I use currently wordpress 3.1.2 and I get the same problem sitemap_index.xml is not generated by Yoast. Do I have to install another sitemap generator?
    http://www.rochegaille-editions.com/
    If I check the link posted by christianebuddy, it seems that the file is not found. (?)
    Thanks in advance for your help

  6. Primitive
    Member
    Posted 3 years ago #

    Are you guys running the W3 Total Cache or other plugins that prevent 404 errors for static files?

    Joost wrote up how to fix such an issue over at
    http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/

  7. Pierre_
    Member
    Posted 3 years ago #

    No trace of W3 Total Cache, and the only plugin dealing with xml files is wordpress-seo.
    I tried also to create an empty sitemap_index.xml and set right to 755 but no way, it is still empty...

  8. Vakantie Ameland
    Member
    Posted 3 years ago #

    Followed all the probable solutions in the how to from joost. Using W3TC, nginx configuration changed as the plugin suggests, removed the old google xml sitemap, adapted .htaccess file but still the WordPress 404 handling.... any good ideas left?

  9. Pierre_
    Member
    Posted 3 years ago #

    Finally I installed Google sitemap XML to generate sitemap.xml and it works. Waiting for the Yoast fix ...

  10. Vakantie Ameland
    Member
    Posted 3 years ago #

    Any solution by Joost?? Still having the xml 404 problem

  11. cassiedong
    Member
    Posted 2 years ago #

    Same, having 404 across three different sites and no WP Total Cache is used.

    Waiting for the fix on this...

  12. budgettravelsac
    Member
    Posted 2 years ago #

    This is F'ed up!! Why in the hell did you do this?? I have no freakin site map now and ALL my titles, meta tags, and keywords are GONE now that I updated this. Now freaking updating this plug in again. What a lot of SHIT I have to deal with right now because of this!

  13. budgettravelsac
    Member
    Posted 2 years ago #

    Seriously, screw you WordPress SEO. Because of this crap, I don't have a sitemap anymore. Tried to generate another one on another site and it didn't work. Screw it - moving to All in One. When you wipe out my entire sitemap and fuck up my meta keywords, titles, I am done with you. You pull this shit and all done behind the scenes. I have to go research this crap because you screwed it up. DONE!!!

  14. ovedmo
    Member
    Posted 2 years ago #

    you have to activate permalinks!!!!

  15. Ahni
    Member
    Posted 2 years ago #

    If you're still getting a 404, you might want to add this handsome looking snippet to your .htaccess file. It worked for me.

    # WordPress SEO - XML Sitemap Rewrite Fix
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^sitemap_index\.xml$ /index.php?sitemap=1 [L]
    RewriteRule ^([^/]+?)-sitemap([0-9]+)?\.xml$ /index.php?sitemap=$1&sitemap_n=$2 [L]
    </IfModule>
    # END WordPress SEO - XML Sitemap Rewrite Fix

    Solution originally posted at: http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-fix-for-sitemap_indexxml-404-error

  16. Marcel Brinkkemper
    Member
    Posted 2 years ago #

    @Ahni THANKS!

  17. Johan82
    Member
    Posted 2 years ago #

    Yes it seems to work, the sitemap is showing up but it's still sending a 404 as the response header which means that Google Webmaster Tool won't find it.

    Any suggestions?

  18. JSPR3
    Member
    Posted 2 years ago #

    @Ahni: Thanks works great!

  19. Joost de Valk
    Member
    Posted 2 years ago #

    Glad it works. Not so glad with the foul language of @budgettravelsac but apparently he can't read.

  20. paologanino
    Member
    Posted 2 years ago #

    Thanks!!! This worked for me! I still have a problem though, my author sitemap returns a blank page, all the others are working fine. Any idea?

    http://www.meridianionline.org/sitemap_index.xml

  21. paologanino
    Member
    Posted 2 years ago #

    Edit: I still get a 404 on google webmaster tools, so strange because now the index and the other xmls (apart from the author one as i stated) are working in the browser.

    General HTTP error: 404 not found
    We encountered an error while trying to access your Sitemap. Please ensure your Sitemap follows our guidelines and can be accessed at the location you provided and then resubmit

  22. Johan82
    Member
    Posted 2 years ago #

    @paologanino as I mentioned above, the snippet above will indeed make the sitemap to show up, but it will still sending a 404 as the response header which means that Google Webmaster Tool won't find it.

    Look at the post http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-fix-for-sitemap_indexxml-404-error to see what caused this problem for me.

    In short, you have probably a plugin or a custom post type that flushes the rewrite rules. I would recommend that you delete the above snippet and disable all plugins except WordPress SEO and then turn them on one by one to see if there is any plugin that is causing this.

  23. paologanino
    Member
    Posted 2 years ago #

    @Johan82 Hey Johan I followed the guidelines from the post you gave but still no luck. Checking with spotlight (i have a local copy of all my files) the only plugin having flush_rewrite_rules(); is wordpress seo itself.

    Right now the index is working just on the browser, the author-sitemap is blank and the news-sitemap is 404. I'm getting mad...

  24. Joost de Valk
    Member
    Posted 2 years ago #

    Don't get mad Paolo, won't help one bit :)

    The sitemaps you linked above work 100% fine except for the news sitemap, you sure you weren't just having a cache issue?

    As for the news sitemap: I'm working on the issues that's giving.

  25. paologanino
    Member
    Posted 2 years ago #

    Thanks Joost,
    after few tricks I got it working again. The author one is not working though, is it maybe because i've changed the author slug?

  26. Joost de Valk
    Member
    Posted 2 years ago #

    Well the author sitemap itself is working fine, it's the XSL that makes it look all spiffy that's not working, but Google should have no trouble whatsoever getting to that XML sitemap.

  27. paologanino
    Member
    Posted 2 years ago #

    Well, webmaster tools tell the opposite..."Sitemap cannot be read". I'm not practical with xsl and xml but i find quite strange that the others are working and this is not. Is the code looking for "author" somewhere? Maybe could be this...

    Thanks so much Joost

  28. paologanino
    Member
    Posted 2 years ago #

    Hi!
    The news sitemap is now working fine after the last update. I'm still getting trouble with the author one though...

  29. Olaf Lederer
    Member
    Posted 2 years ago #

    Hi,
    I have the problem since yesterday after posting a new article.

    It seems to be a problem which is related to some flush rules and custom post types (a premium plugin I installed a few days ago, I will contact the developer of course)

    So I disabled the plugin but I'm still getting a 404.
    What's next? I'm still not having a sitemap :(

    @Joost, why do you create a virtual sitemap and a not physical set of files?

  30. jkohlbach
    Member
    Posted 2 years ago #

    Hi everyone, I'm the developer of the premium plugin Olaf was referring to, ThirstyAffiliates.

    Just thought I would clear up what is actually the cause here since it looks like no one really knows 100% how to fix it.

    The problem is that as plugin developers we normally use init as a point to hook into WP and register our custom post types which is fine. But we also use this point to flush_rewrite_rules(). Which is also fine with one caveat...

    You should only flush the rewrite rules once, on plugin activation.

    To do so, I recommend checking out this great piece of code contributed by clioweb on github:

    https://gist.github.com/871595

    Basically, just register a setting on activation, then during your registration of CPT on the first run through you check for the flag, flush the rules, then remove the setting so it doesn't flush again once the plugin is activated.

    This is the best method I've found and I'll be rolling it out across all my plugins from now on as should other developers utilizing the custom post type framework.

Topic Closed

This topic has been closed to new replies.

About this Topic