WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Wring canonical link on paginated pages (3 posts)

  1. Mark
    Member
    Posted 2 years ago #

    WordPress version: 3.4.1
    WordPress SEO version: 1.2.5 / Development version

    I did this:
    - Installed plugin, configured some default settings

    I expected the plugin to do this:
    - When looking at the <link rel="canonical" href="..."> generated bij the plugin, on the paginated pages (eq. http://www.vind-vacature.nl/page/100), the link should be correct.

    Instead it did this:
    - The link says: href="http://www.vind-vacature.nl/100"
    - When it should say: href="http://www.vind-vacature.nl/page/100"

    Results Google Webmaster indexing a lot of errors:
    - 220 indexing errors because of 220 pages.

    Tried this:
    - Disabled all but WordPress SEO plugin
    - Changed theme to Twenty Ten
    Still having the same problem

    Source can be viewed:
    - In google chrome: view-source:http://www.vind-vacature.nl/page/100

    Incorrect lines:
    21: <link rel="canonical" href="http://www.vind-vacature.nl/100" />
    22: <!-- / Yoast WordPress SEO plugin. -->

    Help please! Thankz

    Kind regards, Mark

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. fighterstyle
    Member
    Posted 2 years ago #

    I have the exact same problem. Not sure what to do...

  3. szepe.viktor
    Member
    Posted 2 years ago #

    Good afternoon!

    The problem is here:
    wordpress-seo/frontend/class-frontend.php:555

    when the frontpage is a paginated static page, yoast seo plugin treat it as a single page, and writes "/2/" into canonical

    there should be another "if (is_front_page()) {} else {}" around line 565 to use get_pagenum_link or simple add the pagination_base option's value (default: "page")

    All the best wishes to you!
    Sz├ępe, Viktor precise webdesign

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic