WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] wpseo can't be created (23 posts)

  1. Beee
    Member
    Posted 3 years ago #

    After 0.2.1 came out last night I installed it on a site of a client, but I get the error "/wpseo/ can't be created"

    /wp-content/uploads = chmod 777
    upload directory hasn't been changed
    added /wpcontent/uploads/wpseo manually but doesn't work either.
    also chmodded /upgrade to 777 to check but wasn't it either.

    Don't know where to look now ? This is a different site than yesterday. If you need info, you know where to find me ;)

    maybe an idea to include the path in the error notice... ?

  2. mbpage
    Member
    Posted 3 years ago #

    Getting the same error myself. Any idea on the fix yet?

  3. Beee
    Member
    Posted 3 years ago #

    yoast told me it depends on with which user WP was installed...

    since I installed the plugin with a different ftp user I used the original one and it works...

  4. werbyvillarino@gmail.com
    Member
    Posted 3 years ago #

    I also have this same problem when installing this plugin, but I did this on first try on the site I migrated to another hosted server.

    Could you tell me the steps on what you did?

  5. Beee
    Member
    Posted 3 years ago #

    I used the original user.

  6. werbyvillarino@gmail.com
    Member
    Posted 3 years ago #

    I'm a newbie to wordpress.

    How do you set the original user or changes to ftp to it?

  7. Beee
    Member
    Posted 3 years ago #

    I used the same user to install the plugin as I used to install WP...

  8. werbyvillarino@gmail.com
    Member
    Posted 3 years ago #

    I can't identify the user from my host server, Is there any other way I could have this fixed maybe checking a particular code?

  9. Beee
    Member
    Posted 3 years ago #

    not that I know of... reinstall it by using the same user is only thing I can give you.

  10. werbyvillarino@gmail.com
    Member
    Posted 3 years ago #

    Its on a different web server all I see on my ftp client on owners/group are numbers and I can't even edit it.

  11. mbpage
    Member
    Posted 3 years ago #

    Have not got anywhere with this. I have installed the plugin via wordpress, uploaded the plugin via wordpress and uploaded the plugin via FTP. It has made no difference. I'm still getting the error. The site only has 1 user so I just don't get it.

    Any suggestions Joost?

  12. Beee
    Member
    Posted 3 years ago #

    did you change the standard upload dir by any change ?
    is wp-content/uploads writable ?

    i wouldn't know any onther thing...

  13. mbpage
    Member
    Posted 3 years ago #

    yeah - it works fine on plenty of other sites just not this one. Even if I delete and reinstall it makes no difference. Site is running the last release of wordpress so I did wonder if that was a problem.

    Hoping Joost might check in and offer a fix. Thanks Bee

  14. Navjot Singh
    Member
    Posted 3 years ago #

    Having the same problem..latest WPSEO and WordPress 3.0.3!

  15. werbyvillarino@gmail.com
    Member
    Posted 3 years ago #

    I still got this problem and for the record I have not yet installed this app when I migrated it to another hosting service and I've also upgraded it to WordPress 3.03

  16. pixeline
    Member
    Posted 3 years ago #

    Had the same error. Fixed it by fixing the path to the wp-content/uploads/ directory in Settings/Medias.

  17. CAS2011
    Member
    Posted 3 years ago #

    I am having two problems.
    1) I get: wpseo could not be created in my Yoast dashboard

    2) I cannot create a sitemap. Is there ANYONE who can help me with simple instructions. I have been trying to find solutions to this for a good week. My wpcontent is writable. I did notice that wordpress seo was uploaded to my plugin file, not my uploads file, although I do have my media settings say to store uploads here: wordpress/wp-content/uploads

    I really don't know what I'm doing here, but I am trying to learn.
    Any assistance would be much appreciated.

  18. chodorowicz
    Member
    Posted 3 years ago #

    Check your "upload_path" record in wp_options table - I had

    /wp-content/uploads
    (with extra slash in the beginning). When I've changed it to
    wp-content/uploads
    the notice dissapeared.

  19. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    In 0.2.3 the error message will be less cryptic and more helpful in actually fixing the underlying issue :) thanks for all the feedback!

  20. stefsegers
    Member
    Posted 3 years ago #

    I have version 0.2.3.1 but still have the strange problem.
    Also I tried to place a new blank file on the server site map.xml and tried it again. Still nothing :(

    Maybe it's WordPress 3.1???

  21. stefsegers
    Member
    Posted 3 years ago #

    After applying 777 to all my folders in wp-content it worked. But I think it should be just 1 folder.... which 1 is it?

  22. stefsegers
    Member
    Posted 3 years ago #

    found it... you have to CHMOD the directory and files in

    wp-content/uploads/wpseo

    good luck all

  23. jeffreyvr
    Member
    Posted 3 years ago #

    For me the problem got solved by deactivating the plugin, and then activate it again.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic