WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
WordPress SEO caused my site to display just white? (44 posts)

  1. PetraW
    Member
    Posted 1 year ago #

    Hi guys, I installed the WordPress SEO Plugin a while back and loved it. Mid June my site just started displaying white - I could go into Wp Admin and do everything normal, but in the web browsers there was only a blank page displayed. After getting in touch with my hosting company, they checked the issue and came back saying that the plugin "WordPress SEO" was causing the issue. I had to disable the plugin and have been too scared to use it again, even though I think it should be ok.
    I just wanted Joost to know that there was an issue and it should maybe get checked. Cheers!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Martin
    Member
    Posted 1 year ago #

    same. i needed to delete the plugin before I could access both the website or Admin

  3. JowiM
    Member
    Posted 1 year ago #

    I fixed this by going to the plugin folder admin/class-admin.php and removed the "s" from update_options() on line 441

  4. Lew Ayotte
    Member
    Posted 1 year ago #

    Yep, JowiM is right... website killing bug with one character :).

  5. JowiM
    Member
    Posted 1 year ago #

    But for me only the admin area was showing white the website worked fine

  6. mpclark
    Member
    Posted 1 year ago #

    Wow, thanks JowiM! The whole back end wasn't working but this fixes it. I expect a lot of other folks will need this over the next few hours...

  7. joomux
    Member
    Posted 1 year ago #

    Thanks JowiM! Worked perfectly!

  8. esmi
    Forum Moderator
    Posted 1 year ago #

    Trying to ping the plugin's developer right now to see if he can confirm the issue and push out an update.

  9. hypedtext
    Member
    Posted 1 year ago #

    Good fix, thanks!

  10. ViOnline
    Member
    Posted 1 year ago #

    thanks JowiM

  11. Max Pen
    Member
    Posted 1 year ago #

    Thanks for the fix!

  12. gcampton
    Member
    Posted 1 year ago #

    Thanks for the info, man WordPress has been so annoying today. I have one site using BackWPup that's giving me cron errors. While the other 5 websites using it on the same server are working fine...
    WordPress SEO stuffing up the whole back-end.
    And an Author description on the bottom of every page I can't seem to remove despite checking all options to remove it, even changing themes. It won't go away.

    Why can't stuff just work!

  13. ingervandyke
    Member
    Posted 1 year ago #

    I can't see my plug in menu because I can't access my dashboard. How do I remove the plugin if I can't see the menu?

  14. JowiM
    Member
    Posted 1 year ago #

    @ingervandyke You can move it from the file system.

  15. Cecy
    Member
    Posted 1 year ago #

    ingervandyke, I have the same problem. I can´t access the back end.

  16. ingervandyke
    Member
    Posted 1 year ago #

    How do I access the file system? Sorry.

  17. princejindal8
    Member
    Posted 1 year ago #

    Thanks JowiM. It fixed the error.

  18. Cecy
    Member
    Posted 1 year ago #

    @JowiM - how do I do that? I never use code and don´t know where the file system is! Can you help with more info please, I´m so worried.

  19. astrasuite
    Member
    Posted 1 year ago #

    Thanks, JowiM ! Solved my Internal Error 500 after installing latest Yoast

  20. esmi
    Forum Moderator
    Posted 1 year ago #

    If you are not comfortable editing the plugin's files, FTP into your site (or use whatever file management application your host provides) & rename:

    wp-content/plugins/wordpress-seo

    to:

    wp-content/plugins/wordpress-seo-old

    This will deactivate the plugin and allow you back into your site.

  21. JowiM
    Member
    Posted 1 year ago #

    @ingervandyke you have to connect to the server using an FTP account. Once you done that you go to {wordpress-path}wp-content/plugins.

  22. photoMaldives
    Member
    Posted 1 year ago #

    awesome, thanks JowiM :)

    For the new users, best method is to use the File Manager in your host account's cPanel. Then navigate to :

    public_html/YOURSITE/wordpress/wp-content/plugins/wordpress-seo/admin

    to find the file : class-admin.php

    then select CODE EDITOR, and remove the 's' as detailed above.

  23. ingervandyke
    Member
    Posted 1 year ago #

    OK so I have downloaded Filezilla but have no idea how to set this up for my site. Do I have to contact my host?

  24. Cecy
    Member
    Posted 1 year ago #

    Would that be my Hostgator account?

  25. esmi
    Forum Moderator
    Posted 1 year ago #

    @Cecy: For your FTP? Yes.

    @ingervandyke: Yes. Or ask them if they have a file management application you can use instead.

  26. Chamomor
    Member
    Posted 1 year ago #

    A big thanks to Thanks JowiM for this perfect solution
    You save a lot of our time

  27. Chad Warner
    Member
    Posted 1 year ago #

    Thanks, JowiM, your solution worked.

  28. johnheaston
    Member
    Posted 1 year ago #

    This just happened to me. Got into File Manager, found the class-admin.php and removed the "s". Now I get this error:

    Parse error: syntax error, unexpected T_GLOBAL, expecting T_FUNCTION in /home/malbarvi/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 508

  29. Loki-Lou
    Member
    Posted 1 year ago #

    Thanks folks! Saw the fatal error on everything I was trying and panicked a bit but your solution worked brilliantly!

  30. sinusrest
    Member
    Posted 1 year ago #

    Many thanks in advance for your help, well now that my blog is up and running as promised...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags