WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] WordPress SEO breaks Blubrry Powerpress Category Podcast RSS feed (6 posts)

  1. Matt Banks
    Member
    Posted 3 years ago #

    First off, I think WordPress SEO is easily the BEST SEO plugin out there!

    I'm having an issue where WordPress SEO is killing off the Category Podcast feed being created by Blubrry Powerpress. If I try to visit the feed with WordPress SEO enabled, I get redirected to the category archive page. If I deactivate WordPress SEO, the category feed works properly.

    The URL format is "domain.com/category/feed/". With the plugin enabled and trying to visit that URL, it redirects to "domain.com/category/".

    Is there any way to fix it so it allows this feed to exist? I would love to keep using the plugin, but I need the podcast feed working.

    Thanks,
    Matt

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Matt Banks
    Member
    Posted 3 years ago #

    Ok, I think I just figured it out. I went through disabling some settings I had enabled, and this one was the problem:

    Permalinks -> Redirect ugly URL's to clean permalinks.

    No idea why the feed URL is considering ugly, but disabling that and clearing cache made the feed work again and Feedburner recognizes everything.

    - Matt

  3. Angelo Mandato
    Member
    Posted 3 years ago #

    Glad to see this problem has been resolved.

    We have answers to many other PowerPress questions at our forums at forum.blubrry.com.

  4. criography
    Member
    Posted 3 years ago #

    Hi Yoast,

    I had very similar problem as described above but after few hours of investigation I found the reason. First of all it will only break on nested categories - so for example on /news/feed/ it will work OK, yet on /news/events/feed/ it will redirect to the actual category view instead of the rss.

    The guilty bit is in class-rewrite.php in line 83. The moment I replaced
    'index.php?category_name='.$category->slug.'&feed=$matches[2]'; with 'index.php?category_name=$matches[1]&feed=$matches[2]'; and disabled->reenabled the option, the values in the DB were refreshed and everything went back to normal.

    I don't know if it's a mistake or something changed in WP recently but I thought I should let you know.

    Otherwise awesome work as usual! (:
    Thanks!

  5. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    This should have been fixed in 0.2.2 yesterday :)

  6. Matt Banks
    Member
    Posted 3 years ago #

    I'll have to try re-enabling that setting now :)

    Thanks!
    - Matt

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic