WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] WordPress didn't return a valid path to your upload directory. (6 posts)

  1. Daniel Craig Jallits
    Member
    Posted 3 years ago #

    WordPress SEO plugin returns the error "WordPress didn't return a valid path to your upload directory, please make sure your upload path is set correctly" on the plugin Dashboard.

    The Problem: The plugin is trying to create a sub-directory in uploads for the wpseo directory. The plugin correctly checks to see if the uploads directory is available. If not, it generates the error. If it is present it creates the wpseo directory.

    Suggested fix: The plugin should create the uploads directory, based on the default or custom value set in Media under Settings.

  2. aphnee
    Member
    Posted 3 years ago #

    Hi,

    I have a somewhat special setting for my upload directory. I have a subdomain pointing to another server (more optimized for static content) where all my uploads goes to. My settings are:

    Store uploads in this folder: "../../../static.domain.se/public_html"
    Full URL path to files: "http://static.domain.se"

    Any suggestion how to solve this?

  3. brendontudor
    Member
    Posted 3 years ago #

    Hi,

    Thank you, but your 'suggested fix' is not a fix; you have just stated what is supposed to happen when you install the plugin. I am also getting this error and would like to know how to resolve this. What should the permissions be on the 'uploads' folder? I already have the 'uploads' folder present but I still get this error. I have tried with 'wp-content/uploads' in the 'Store uploads in this folder' field (in Settings > Media) and have also tried with this field left blank. I have also deleted and reinstalled the plugin but still get the error.

    Please advise. Thank you.

    Brendon

  4. Dix-Onze
    Member
    Posted 3 years ago #

    Try this :
    In Settings > Media
    Uncheck "Organize my uploads into month- and year-based folders"
    Work for me.

  5. brendontudor
    Member
    Posted 3 years ago #

    Thank you dixonze. This has worked. I also had to change permissions on the "uploads" folder. Thanks again for your help.

  6. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    That is indeed the fix, later versions of this plugin will no longer write files for XML sitemaps, as that is just one big cesspool of issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic