WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] URGENT: Title tags blank on every post / page. (8 posts)

  1. rick4him
    Member
    Posted 2 years ago #

    I recently changed my theme to one that was 'audited' by Yoast and after changing to this theme, I'm getting no titles on any page now. I tried adding %%titles%% to the template in the plug in settings; and tried entering in custom titles in the title box on each post. It doesn't matter. I have no titles on any page. This is a pretty serious issue and I need to get it fixed asap. I'm hoping someone has an idea how to get this fixed, asap.

    Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    I'm assuming you got it fixed?

  3. rick4him
    Member
    Posted 2 years ago #

    The company that makes the theme said you had audited their code and everything would work. Turns out I had to check the "overwrite titles" box in the plug in to get it to work. I didn't have to do this on the previous version of their theme. I see it says it takes longer this way. Is there a way to get it to work without doing this?

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Hmm they should've fixed that :) Just apply the changes proposed on the SEO -> Titles page to the title tag.

  5. rick4him
    Member
    Posted 2 years ago #

    Hmmm..the theme had <title><?php wp_title(''); ?></title> and I still had to check the box to force rewrite. I didn't check that box at first, thinking it was working since they said you had audited their code. Turns out it wasn't working, and it actually stripped every title out of all of my pages. I didn't notice it until I got a warning that every page was missing a title tag.

    Any ideas why I had to check that force rewrite title even with the <title><?php wp_title(''); ?></title> in the theme?

    I'll be glad to post any source code if needed. Thanks for your help.

  6. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    It's a bug on their end, just encountered it in another thread too. Please file a support request with them, I'm emailing them too.

  7. rick4him
    Member
    Posted 2 years ago #

    They actually asked me to change themes when I brought it to their attention stating that "they are unable to provide me with the sort of service I need since I require such "specific" needs." So I am unable to file a bug report.

    I was taken back that they suggested this, since on their blog they stated that you audited their software (which I assumed meant that everything worked fine.) I was disappointed that they choose to handle it this way. I like their theme a lot, and was just trying to bring something to their attention.

    For now should I just check "force rewrite titles" or is there something else I should do to fix it?

  8. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Just use force rewrite for now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic