WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Updated to the latest version and the admin area gives a Server err (12 posts)

  1. TechHamlet
    Member
    Posted 1 year ago #

    I just updated to the latest version the plugin and as soon as its updated, I can't go the the admin ares! The rest of the site works without any issues. But the admin area gives me a "Server error". Here's a screenshot of the error : http://ge.tt/6IISOmM/v/0?c

    Note : I use Nginx on my server!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. yalamber
    Member
    Posted 1 year ago #

  3. nix255
    Member
    Posted 1 year ago #

    Same for me, I just updates wordpress SEO and have this error in the admin and white screen: Call to undefined function update_options() in /home/~/public_html/~/wp-content/plugins/wordpress-seo/admin/class-admin.php

    I deleted the plugin via ftp and all works again, installing the plugin again and it's ok until its activated.

    WordPress version 3.4.1
    Wordpress SEO by Yoast upgrade to version 1.2.8.

  4. Alain Schlesser
    Member
    Posted 1 year ago #

    Same here...
    Wordpress version 3.4.1
    Wordpress SEO by Yoast upgrade from 1.2.7 to 1.2.8

  5. utnalove
    Member
    Posted 1 year ago #

    I also have the same!! Please help, I don't want to loose the existing configuration.

    Fatal error: Call to undefined function update_options() in /home/site/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441

    What can I do? maybe for the time being we can edit the class-admin.php or something else and gain access to the wp-admin? And then you'll create a new version with the error corrected?

  6. nix255
    Member
    Posted 1 year ago #

    @utnalove delete the plugin via ftp to regain access to the admin panel. The SEO settings will be retained in the database so you won't lose them.

  7. TechHamlet
    Member
    Posted 1 year ago #

    Fixed it :) According to this post : http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-wordpress-seo-caused-my-site-to-display-just-white?replies=7#post-3118453

    Edit the file wp-content/plugins/wordpress-seo/admin/class-admin.php
    Search for the word update_options and make it update_option

  8. utnalove
    Member
    Posted 1 year ago #

    Thanks... the update_options changed to update_option corrected the error.

  9. photoMaldives
    Member
    Posted 1 year ago #

    same problem here - thanks for the link

    (does no one beta test any more ?? :-) )

  10. bchignell
    Member
    Posted 1 year ago #

    Removing the 's' worked for me, cheers! - deleted plugin though out of principle :)

    How did this pass testing?!

  11. felixcat
    Member
    Posted 1 year ago #

    I too have had this problem.

    Thanks for the workaround.

    But I trust this error will be corrected by Yoast shortly.

    I hate having to go into php files and mess around with code there manually. That negates the whole point of using a plugin!

  12. darrenjhayes
    Member
    Posted 1 year ago #

    I had the same issue. If you have FTP access to your site, here's a quick way to resolve the issue:

    Fix for Yoast SEO update problem

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.