WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Tour Won't End (14 posts)

  1. winterlong
    Member
    Posted 2 years ago #

    Based upon multiple recommendations, I've installed WordPress SEO by Yoast.

    I'd like how to learn to use it, but I'm challenged by the need to hit the "close" button of the plugin's tour each and every time I do anything within the administration area of my WP site.

    I've searched out a way to disable the tour and cannot find one. I do see from searching on Google that at one time there was a "stop" option that was removed in the last few updates.

    How do I convince WP SEO by Yoast that I've taken the tour and no longer need to see its pop-up windows?

    Thank you.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Radek Kucera
    Member
    Posted 2 years ago #

    I have same problem on my WPMU network.
    :(

  3. winterlong
    Member
    Posted 2 years ago #

    I solved this problem and should have posted my solution earlier.

    It turns out that because of the default permission settings (which couldn't be changed) assigned by my web hosting service to the files and folder I uploaded via FTP, my plugins were not functioning properly.

    My solution was to switch web hosts. With my new host, and the correct permissions being assigned, I'm getting full functionality not just from WordPress SEO by Yoast but from the other plugins I am using.

    Now that I can actually use it, I highly recommend WordPress SEO. It's really working great for me and my first website.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Great to hear that winterlong!

  5. Radek Kucera
    Member
    Posted 2 years ago #

    winterlong: Please could you specify concrete "permission settings"? I will ask my hosting provider too.

    FYI I have VPS, I can setup what I want.... but need to know what to setup.

    Thanks!

  6. winterlong
    Member
    Posted 2 years ago #

    I was on a shared server when the problems were occurring. After some Googling, I found that my original host was infamous for problems with WordPress and permission settings.

    For example, files which I needed to be 644 would be 640 and folders which I needed to be 755 would be 750. Changing them individually or en masse via cPanel's File Manager or FTP did not always solve the problem. Sometimes they would revert back to their original settings.

    After a lot of troubleshooting and hassle, the simplest solution was to switch to another host and, why not?, to VPS.

    Two good resources:
    http://codex.wordpress.org/Changing_File_Permissions
    http://wordcastnet.com/2011/managing-file-permissions-in-wordpress/

    Good luck, bigdrobek.

  7. Radek Kucera
    Member
    Posted 2 years ago #

    WPMU 3.3.2 + WPSEO 1.1.9

    I have no problem with file permissions or ownership :(
    Only one think I can imagine can do mess in WordPress seo it that i have ranamed wp-content

    Here is what i found in debug.log, I dont know if this is connected with my problem :(

    [27-May-2012 17:58:49] PHP Notice: Undefined index: paged in /var/...../web/obsah/plugins/wordpress-seo/frontend/class-frontend.php on line 323

    [27-May-2012 19:49:59] PHP Notice: Undefined index: post_title in /var/...../web/obsah/plugins/wordpress-seo/inc/wpseo-functions.php on line 271

    [24-May-2012 18:55:14] PHP Notice: Undefined offset: 0 in /var/......./web/obsah/plugins/wordpress-seo/frontend/class-breadcrumbs.php on line 174

  8. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    It's not.

  9. Radek Kucera
    Member
    Posted 2 years ago #

    I've tested this plugin on diferent hosting provider and I have similar problem "Tour wont end" Firstly it was VPS, right now I tested it on webhosting.

    Anyone have this error and solved it? How?
    winterlong: Please could you more specify the writing rules problem?

  10. Radek Kucera
    Member
    Posted 2 years ago #

    I found alternative solution for this error - plugin "Disable Pointers", but I think it is not clear solution for this. There could be some misconfiguration on my website/hosting which I donˇt know :(

  11. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    I'm guessing another plugin or your server is preventing the needed AJAX call from happening...

  12. Fred
    Member
    Posted 1 year ago #

    @winterlong, can you specify which files' permissions needed changed and to what?

    Right now, I'm on cheap GoDaddy hosting but would like to figure out if it's a hosting issue before making a switch.

  13. Kim_Diamond
    Member
    Posted 1 year ago #

    So glad it found this thread. I found this searching on Google. I have already posted about this earlier.

    Yes, I am having that tour button problem. Plug-in worked fine now it wont go away.

    I would try to switch theme afraid it would mess up all my themes setting and side bar setting. took me days to customize my themes.

    Here is my theme shot

    http://screencast.com/t/O1ignWucrEd

    So looks like not solution.

    Anyone tried switching to another theme.

    http://www.InternetAdvertisingDeals.com - theme setting with banner ads and amazon setting is all customized and took days I would hate to switch themes and lose setting.

    Thanks Kim D.

  14. Kim_Diamond
    Member
    Posted 1 year ago #

    Problem Resolved:

    I deleted the plugin =

    Use Google Libraries
    Allows your site to use common javascript libraries from Google's AJAX Libraries CDN, rather than from WordPress's own copies.
    Version 1.5 | By Jason Penney | Visit plugin site

    http://jasonpenney.net/wordpress-plugins/use-google-libraries/

    I added this plugin to solve another problem.

    As soon as i deleted this plugin the Yoast offered me another options on the POP UP.

    I also did this prior to deleting the "Use Google Plugin"
    I went into my cpanel - wp content - plugins - wp seo Yoast pluging and changed permission to 777 - then refreshed the browser.
    Then I deleted the "Use Google Plugin"

    UNRESOLVED
    Problem Still Need To Be Fixes
    Focus Keyword
    Find Related Keyword
    Spinning Wheel
    Option Appear Top of WordPress Right Hand Side

    RESOLVED
    Dash Board Appearing Long Under The Post Page:
    Go into options and uncheck the box title post. Post Page will go back to normal size.

    Thank all of you for your support and Yoast "Love The Plugin"

    Kim Diamond
    Internet Advertising Deals

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic