WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Title ,custom post type and Page // PROBLEM (14 posts)

  1. vincegx
    Member
    Posted 2 years ago #

    Hello !
    I looked at many forums, site without finding a solution.
    For my theme I use for my home page and portfolio page of type "custom post type" that I used to skin This two page!
    I created two main pages in wordpress and have associated templates for these pages ("custom post type")

    On the other hand, I use wp_title ('') in my header.php and I do not make rewriting.
    (I also tested with the rewriting but this has not solved my problem)

    For the classic pages, which are not associated with "custom post type", no problem my titles, description and keywords works perfectly.

    But these two pages, can not display title description and keywords.

    For the title I have to do like this:
    <title> <? php if (is_home ()) {echo bloginfo ("name") echo "|" echo bloginfo ("description")} else {echo wp_title ('-', true, 'right') ;}> </ title> but it's not very cool ... but only for display the title .....and title displayed identical in my two page .... and i don't want this...)

    My question is how to display title, description and keywords on these two pages using the plugin!
    I am Developers, so the code doesn't scare me, but I confess I block ..

    I installed wordpress 3.3 and wordpress 1.1.1 SEO

    PS: Sorry for my English, I'm French .. :)

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Dude, you're english is so bad that I have no clue what you're trying to say. Try French :)

  3. vincegx
    Member
    Posted 2 years ago #

    ok ! ok I'll try to be more explicit !
    your plug-in and also all in one seo have a problem with the "custom post type" and the archive page.

    I read in many forums and website, when using an archive page, which lists "custom post type" associated, no title or description (title and description filled with plugin) are displayed.

    I must complete two pages on my archive with titles and descriptions like this.

    <?php if(is_home() && $post_type != 'plugin') {
    	echo '<meta name="description" content="descriptifbablabal"/>'."\n";
    	echo '<link rel="canonical" href="' . esc_url( get_permalink( get_queried_object() ), null, 'other' ) . '" />'."\n";
    	}
    	elseif( $post_type == 'plugin2' && is_null($plug3)) {
    	echo '<meta name="description" content="blabla2"/>'."\n";
    	echo '<link rel="canonical" href="' . esc_url( get_permalink( get_queried_object() ), null, 'other' ) . '" />'."\n";
    	}?>

    For Pages "custom post type", it works by the section title of your plugin, but for the archive pages your plugin does not work ....

    U'r understand better ?

    Thx Joost

  4. vincegx
    Member
    Posted 2 years ago #

  5. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    If you go to the SEO -> Titles page and scroll down, you can set titles and descriptions for each Custom Post Type archive?

  6. vincegx
    Member
    Posted 2 years ago #

    Yes for sure , but just for the custom post type, not for the archive dépend of custom post type .....
    Verify Joost , à lot of post and forum speak about this problem .....

    12 hours about this problem , perhaps 100 post read And Tryed noi solution ...... U want URL of my website ?

  7. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    No, a lot of forums SPOKE about this issue because it was solved in the past. Could you show me the code you use to generate your custom post type? I think you don't have the custom post type archive enabled there, because this:

    http://uploads.yoast.nl/cpt-archives-20111216-090909.png

    is what I get for MY custom post type archives on the SEO -> Titles page. I do verify, I just think something is wrong on your end :)

  8. vincegx
    Member
    Posted 2 years ago #

    add_action( 'init', 'create_my_post_types' );
    function create_my_post_types() {
    	register_post_type( 'pb_portfolio',
    		array(
    			'labels' => array(
    				'name' => __('Photos', "pb"),
    				'singular_name' => __('Portfolio item', "pb"),
    				'add_new_item' => __('Add new Portfolio item', "pb"),
    				'edit_item' => __('Edit Portfolio item', "pb"),
    				'view_item' => __('View Portfolio item', "pb"),
    				'search_items' => __('Search Portfolio items', "pb"),
    				'not_found' => __('No Portfolio items found', "pb"),
    				'not_found_in_trash' => __('No Portfolio items found in Trash', "pb"),
    			),
    			'public' => true,
    			'show_in_nav_menus' => true,
    
        'publicly_queryable' => true,
        'show_ui' => true,
        'show_in_menu' => true,
        'query_var' => true,
        'rewrite' => true,
        'capability_type' => 'post',
        'hierarchical' => false,
    
    			//'menu_position' => 5,
    			//'menu_icon' => get_bloginfo('template_directory') . "/images/admin_icons/projection-screen.png",
    			'supports' => array('title', 'editor', 'thumbnail', 'excerpt', 'comments', 'custom-fields'),
    			'has_archive' => 'portfolio',
    		)
    	);
    
    	register_post_type( 'pb_homeslide',
    		array(
    			'labels' => array(
    				'name' => __('Home slides', "pb"),
    				'singular_name' => __('Home slide item', "pb"),
    				'add_new_item' => __('Add new Home slide item', "pb"),
    				'edit_item' => __('Edit Home slide item', "pb"),
    				'view_item' => __('View Home slide item', "pb"),
    				'search_items' => __('Search Home slides', "pb"),
    				'not_found' => __('No Home slides found', "pb"),
    				'not_found_in_trash' => __('No Home slides found in Trash', "pb"),
    			),
    			'has_archive' => true,
    			'public' => true,
    			'exclude_from_search' => true,
    			'show_in_nav_menus' => true,
    			//'menu_position' => 5,
    			//'menu_icon' => get_bloginfo('template_directory') . "/images/admin_icons/projection-screen.png",
    			'supports' => array('title', 'thumbnail', 'custom-fields'),
    			'has_archive' => false,
    			'rewrite' => array('with_front' => true, 'slug' => 'hs' ),
    		)
    	);
    }

    Thx professor for my mistakes in English ;)

    it's true, I do not see my custom post type archive in the section 'title' of your plugin .....

  9. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    You have "has_archive" set to false, so of course you won't see it as according to your own declaration, your custom post type doesn't have an archive.

  10. vincegx
    Member
    Posted 2 years ago #

    Yes , i change for True ....but no resolution ..... and delete the similar declaration of has_archive .... same problem ....

  11. vincegx
    Member
    Posted 2 years ago #

    And the Guy who buid the theme say

    For the home page and portfolio archive page, you create pages with custom template set up (Home slides or Portfolio page). You may want to check how Yoast handles that, I believe for Yoast it looks different, not like the regular page and this is why it ignores what you enter in page settings.
    ....

  12. jwind
    Member
    Posted 2 years ago #

    hmmmmm, I to am missing the title and description. Just getting site name on CPTs.

    add_action('init', 'codex_custom_init');
    function codex_custom_init()
    {
      $labels = array(
        'name' => _x('Rides', 'Ride'),
        'singular_name' => _x('Rides', 'Ride'),
        'add_new' => _x('Add New', 'Ride'),
        'add_new_item' => __('Add New Ride'),
        'edit_item' => __('Edit Ride'),
        'new_item' => __('New Ride'),
        'all_items' => __('All Rides'),
        'view_item' => __('View Ride'),
        'search_items' => __('Search Ride'),
        'not_found' =>  __('No Rides found'),
        'not_found_in_trash' => __('No Rides found in Trash'),
        'parent_item_colon' => '',
        'menu_name' => 'Rides'
    
      );
      $args = array(
        'labels' => $labels,
        'public' => true,
        'publicly_queryable' => true,
        'show_ui' => true,
        'show_in_menu' => true,
        'query_var' => true,
        'rewrite' => true,
        'capability_type' => 'post',
        'has_archive' => true,
        'hierarchical' => false,
        'menu_position' => null,
        'supports' => array('title','editor','author','thumbnail','excerpt','comments')
      );
      register_post_type('Rides',$args);
    }

    Gonan take a closer look, but thought I'd chime in...

  13. jwind
    Member
    Posted 2 years ago #

    hmmm, make that just on CPT Single pages...

  14. jwind
    Member
    Posted 2 years ago #

    Nope, sorry I'm good. My template tags were the problem. Bad setting.

    Thanks for what I think is the best SEO WP plugin Joost. Kudos.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic