WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Social: can't select page as Facebook admin (33 posts)

  1. Edward Seid
    Member
    Posted 2 years ago #

    Plugin version 1.1.1

    I administer 7 Facebook pages. When I try to select a page to use as Facebook admin, it only lists 3 pages, not all of them.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. murrayac
    Member
    Posted 2 years ago #

    Same here

  3. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    can I ask for both of your facebook usernames? Might be able to do some debugging...

  4. murrayac
    Member
    Posted 2 years ago #

    Murray Anderson-Clemence
    http://www.facebook.com/profile.php?id=568459094

    Thanks

  5. Edward Seid
    Member
    Posted 2 years ago #

  6. brittanybotti
    Member
    Posted 2 years ago #

    This happens to me as well...I manage over 20 pages and have about 10 apps, and the drop downs only show one page and one app. Facebook username is facebook.com/brittanybotti

  7. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Might have found the issue, possible patch in 1.1.2

  8. murrayac
    Member
    Posted 2 years ago #

    Cool!

  9. Edward Seid
    Member
    Posted 2 years ago #

    I upgraded to plugin version 1.1.2

    Clicked "Update Facebook Pages" button and received message "Successfully retrieved your pages from Facebook, now select a page to use as admin"

    However, only 3 pages are listed. This is the same behavior as the previous version... problem not fixed.

  10. murrayac
    Member
    Posted 2 years ago #

    Same as @Edward

  11. skipshean
    Member
    Posted 2 years ago #

    +1. I have like 15 facebook pages and it is only showing me one of them when I refresh pages.

  12. Rob Roy
    Member
    Posted 2 years ago #

    +1. I Administer 5 Facebook Pages, only 1 of them shows up. Further, if I choose Facebook apps, I have 4 of them enabled on my developer account, only one of those shows up too.

  13. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Argh, ok sorry folks, going back to the drawing board and try to fix again :)

  14. natbeley
    Member
    Posted 2 years ago #

    I am so happy I found this because I am setting up the wordpress seo for the first time and I am having the same problem. I am an admin on 2 sites and only 1 is available for me to choose.

    Thank you!

  15. Tomas Mackevicius
    Member
    Posted 2 years ago #

    Same issue :(

    I administer 4 FB pages, but none of them is listed, just "Do not use FB page as admin".

    May I ask to add those 2 fields with OpenGraph data back? Then people who now what they are doing will not have to complete 20 steps to add info for 2 fields.

    Otherwise super plugin! Big thanks!

  16. IasoW
    Member
    Posted 2 years ago #

    Is there an update on this issue yet? I still have the same issue in that my page is not listed, only the "Do not use FB page as admin". Please let us know if this will be resolved anytime soon Joost de Valk.

  17. swisss
    Member
    Posted 2 years ago #

    I've upgraded to the latest version 1.1.4 and am very disappointed to find that the fields where I had previously entered Facebook page ID and Facebook admin ID have disappeared (unless I've not looked hard enough) and I am now being forced to use a 'Wordpress SEO by Yoast' app to enter this info.

    Like other users here I have many Facebook pages and as such I wish to continue using the ID fields as in the previous version. This was working perfectly and whilst I having nothing against FB apps and have several in use, I do not want to have to use a third party app for this purpose.

    Is it possible to downgrade / revert to the previous version of Yoast SEO that had the FB ID fields? Or is there a workaround?

    Many thanks

  18. audvin
    Member
    Posted 2 years ago #

    Experiencing the same bug. Only lists 7 Facebook Pages, same ones shows up every time, not random.

  19. Eric R. Stoeckel, Jr.
    Member
    Posted 2 years ago #

    I currently administer 3 Facebook pages and only one shows up for me as well.

  20. Todd
    Member
    Posted 2 years ago #

    Has any solution been found here? I have many pages and apps I'm an admin of but the plugin only grabs one page. Please help! Incase needed, the username I have on Facebook is ../tedelman

  21. Mathias
    Member
    Posted 2 years ago #

    same here with 1.1.5. I have only one page and it does not receive it :( I only have the option "Do not use a Facebook Page as Admin"

  22. Edward Seid
    Member
    Posted 2 years ago #

    Version 1.1.5 Social still doesn't work BUT I think I have a workaround.

    You can do this 2 ways, either with phpMyAdmin or the plugin's import/export feature. In either case, you need the FB Page ID. You can find it by visiting the Page you wish to make admin, click "Edit Info" and find the ID in the address bar.

    Next, go to the Social menu and set things up the way you want with using ANY Page. It doesn't matter what Page you choose because you're gonna replace the Page ID with the right one. Be sure to click Save.

    OK, now you have two ways to proceed. Just choose the one that's easiest for you.

    1. phpMyAdmin

    In table wp_options, find option_name = wpseo_social. Edit it and look for fbadminpage followed by a long string of numbers in double quotes. Replace the long numeric string with the FB Page ID of the CORRECT page. Save and DONE! :)

    2. Import/Export

    Export the current settings, unzip on your local machine and edit the settings.ini file. Near the end, look for fbadminpage = "a long numeric string". Replace the long numeric string with the FB Page ID of the CORRECT page. Save the file. Zip and save as settings.zip. Use Import feature (you may have to click the Social menu item again for it to reappear at the bottom). DONE! :)

    I hope this workaround helps those who have been waiting for a proper fix. Enjoy!

  23. Dustin
    Member
    Posted 2 years ago #

    Edward, I used your second workaround successfully.

    The feature to automatically pull the app id from Facebook is really neat but maybe it would just be easier to leave a blank field for the user to manually type the number in.

  24. diggie72
    Member
    Posted 2 years ago #

    I tried Edward's second option as well, and replaced the string with the correct ID, unfortunately, all I got back was an empty field in the "Select a page to use as Facebook admin" drop-down so I'm not sure what I've achieved.

    I can also only see one page in the drop-down whilst I have a lot more on FB.

  25. greyhatguru
    Member
    Posted 2 years ago #

    Can't we just add the ID in manually? I can't get mine to select my page. I administer 13 and have 1 showing.

  26. udipl
    Member
    Posted 2 years ago #

    +1
    I also tried Edward's second option as well, and replaced the string with the correct ID, and the meta tag is now ok.
    I don't expect the UI to work, but I haven't checked.

  27. Mike Zielonka
    Member
    Posted 2 years ago #

    Hey Yoast!

    I have about 10 apps and 20 pages on my social account...Wordpress SEO still only pulls 1 per page and application.

    Just wanted to drop you an update that the issue still is out there :/

    Any chance we could just get an option to manually enter the app id...kind of like how your analytics give you the option to automate our manually enter?

    Mike

  28. Jabawack
    Member
    Posted 2 years ago #

    Same Problem here...

  29. Energias
    Member
    Posted 2 years ago #

    Pages with numbers still doesn't show . . .

  30. Adam
    Member
    Posted 2 years ago #

    Same issue

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic