WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Sitemap not working (25 posts)

  1. yipbop
    Member
    Posted 3 years ago #

    Hi,

    I updated the plugin to Version 0.4.1 on 2 of my websites. When I visit 1 site, http://vintage-ring.com/sitemap_index.xml , the sitemap shows zero URLs, the other site, http://seoplugin.info/sitemap_index.xml , takes me to the homepage.

    How can I fix this?

    Thanks,
    Yip

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    The first URL is working absolutely fine, though it could use a caching plugin. It's a sitemap so it links to 4 other sitemaps. Why the second redirects to the homepage I don't know yet, I'll try to find out.

    Could you give me some details on that site? Which WP version, any caching running?

  3. godsboy7777
    Member
    Posted 3 years ago #

    Hi there Joost.

    Here is my URL.

    http://www.godsboy.org/sitemap_index.xml

    Here is a list of plugins running and the latest wordpress
    Akismet
    Better Blogroll
    Broken Link Checker
    cbnet Ping Optimizer
    Dagon Design Sitemap Generator
    Easy AdSense
    Fast Secure Contact Form
    Flash Video Player
    Google Video Sitemap
    Nofollow Links
    Paypal Button Generator
    Plugin Central
    PubSubHubbub
    Redirection
    Secure WordPress
    SEO Smart Links Business
    SexyBookmarks (by Shareaholic)
    SI CAPTCHA Anti-Spam
    Simple Tags
    StatPress
    To Title Case
    Use Google Libraries
    W3 Total Cache
    WordPress SEO
    WP DB Optimizer
    WP Minify
    WP Smush.it
    WPtouch
    Yet Another Related Posts Plugin

  4. yipbop
    Member
    Posted 3 years ago #

    Thanks for the reply,

    The 2nd URL is using WordPress Vs. 3.1.3
    Cache Plugin: W3 Total Cache

  5. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    You probably have the part in W3 Total Cache -> Browser Cache active that says to not handle 404's for static files within WordPress? If so, add this exception:

    sitemap(_index)?\.xml

  6. godsboy7777
    Member
    Posted 3 years ago #

    Joost you rock!! Thanks man love your work and plugin.

    Dunno how you going to enable this to auto config w3 total cache or maybe get them to add it in future releases?

    Last question.

    Does one submit each sitemap listed in index sitemap to Google webmaster tools?

  7. Hector
    Member
    Posted 3 years ago #

    Hey godsboy7777... not that it's any of my business but do you need WP Minify if you already have W3 Total Cache?

    Just a thought.

    :)

  8. godsboy7777
    Member
    Posted 3 years ago #

    Only use WP minify for the js css and html combine and minification w3 total cache's not as good.

    anyways to fix the problem when using browser cache settig:

    Do not process 404 errors for static objects with WordPress.

    add this to the exception list and problem solved.

    sitemap(_index|[0-9]+)?\.xml(\.gz)?

  9. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Check this new post: http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/, this answers all your questions / issues.

  10. yipbop
    Member
    Posted 3 years ago #

    OK, I figured out how to fix this issue by going to the Permalinks setting of WordPress SEO, and unchecking "Redirect ugly URL's to clean permalinks"

    Works beautifully now.

  11. Vicki Kron
    Member
    Posted 3 years ago #

    Yesterday all the WordPress SEO information was showing on every post. Today - not showing on any post. Where did it go and how do I get it back? I tried deactivating the plug-in, then adding it back, but WP says it's already installed.

    I think I did something to mess it up. I'm just learning the technical side of things, so not too experienced.

  12. Vakantie Ameland
    Member
    Posted 3 years ago #

    Same here... 404 page, no errors.. , used the w3tc browser cache tips. No errors in w3tc config.... Try for yourself: http://blog.christianebuddy.com/sitemap_index.xml not found..... grrr

  13. godsboy7777
    Member
    Posted 3 years ago #

    Did you add this to the browser cache exception list?

    And did you make sure your .htaccess file was updated accordingly?

    Do not process 404 errors for static objects with WordPress.

    add

    sitemap(_index|[0-9]+)?\.xml(\.gz)?

    I see if you update W3 Total Cache it does not change this entry automatically if you already using W3 Total Cache.

  14. Vakantie Ameland
    Member
    Posted 3 years ago #

    Did all the above and nevertheless not working.. http://blog.christianebuddy.com/sitemap_index.xml Any solution anyone?

  15. Morten Okkerholm
    Member
    Posted 3 years ago #

    Various redirection plugins can also cause this. I have seen this happening with the Permalink redirect plugin from scott yang http://scott.yang.id.au/code/permalink-redirect/

  16. azbigmedia
    Member
    Posted 3 years ago #

    I have checked http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/ and do not have W3 Total Cache but get the 404 error.

    Any other suggestions?
    aznow.biz

  17. Stergos
    Member
    Posted 3 years ago #

    Today i try more than 10 sitemap plugins like this one, non works. Go back to A1 sitemap generator...

  18. Pepperbase
    Member
    Posted 2 years ago #

    Following error displays when I open sitemap:

    This page contains the following errors:

    error on line 2 at column 6: XML declaration allowed only at the start of the document
    Below is a rendering of the page up to the first error.

    see: http://www.pepperbase.com/sitemap_index.xml

    Suggestions?

  19. rlgrobert
    Member
    Posted 2 years ago #

    I'm getting the same thing—a WordPress 404. I've never used the W3 Total Cache plugin. It was working fine until two days ago when I updated from 4.something to 1.0.1.

    Any other reasons? Thanks.

  20. rlgrobert
    Member
    Posted 2 years ago #

    I meant upgraded from 0.4.something....

  21. TechHamlet
    Member
    Posted 2 years ago #

    If you have an Nginx server, remove any rules applied to the robots.txt and it might work! It worked for me!

  22. TechHamlet
    Member
    Posted 2 years ago #

    After removing robots.txt rules, after rebooting the server, I got the error again! So, I tried this :

    In W3Total Cache, under Browser Cache, try to disable "Set W3 Total Cache header" for HTML & XML and then restart Nginx and try again! It worked for me :)

  23. Cengiz Taskin
    Member
    Posted 2 years ago #

    Just empty cahce and press save settings button in sitemap xml section.
    .Then refresh the page, that is it
    This is how I solved my problem in my blog

  24. tastymouse
    Member
    Posted 2 years ago #

    Hi Pepperbase, you've got it working correct now. Can you tell us how you solved your problem?

  25. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Please open a new thread if you've still got issues with this, closing this one.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic