WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Sitemap created but not found for main site (only) (2 posts)

  1. cshrimpt
    Member
    Posted 3 years ago #

    Hi,

    First, the SEO plugin is great. However, I'm having trouble with the sitemap function. It works fine for all the subdomain sites, but it's not working on the main site. The map is generated, but going to domain.com/sitemap.xml redirects to the main blog with an access denied / not found message.

    However, when accessing subdomain.domain.com/sitemap.xml the sub site's customized map is returned.

    Looks like a rewrite issue for the main site. How do I go about troubleshooting this? It doesn't look like there are any .htaccess rules specific to the seo plugin.

    Plugin ver is 0.2.1 on wp 3.0.1 with buddypress 1.2.6

    Thanks,

    Craig

  2. cshrimpt
    Member
    Posted 3 years ago #

    Can anyone help me with this issue? The sitemap for my main site is broken. I can put a symbolic link in my blog's root directory to the sitemap in the wpseo directory and retrieve the map. However, if I do this all the site maps for the sub blogs stop working. If I remove the link, the sitemap for the main blog's URL redirects to a 404. I.e., the plug-in can't find it.

    If someone knows how the plug-in finds the sitemap for the main site, maybe I can figure out a workaround.

    Thanks,

    Craig

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic