WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Site Title being appended to Site Description (7 posts)

  1. JaysonFoxx
    Member
    Posted 2 years ago #

    WordPress version: 3.4.1
    WordPress SEO version: 1.2.5

    First off, yet another AMAZING plugin Joost!! Best SEO plugin EVER!! Nice work!

    I did this: Our 'site name' keeps getting appended to the end of our page title. Here is a link to one of our homepage ( but it's happening to all of our pages): http://sosdeploy.com/

    When you click on the URL above then mouse-over the tab in your browser (we are using Chrome but it happens in all browsers) you get the following title:
    "SOS Deploy | OS Deployment, Reimaging, Migration & Disk Imaging ToolsSOS Deploy"

    Actually if you click on any of the menu items and look at the title displayed on the tab in the browser you will see the Site Name (SOS Deploy) is being appended to the Site Description. Actually it is being appended no matter what variable we use in the plugin.

    Here are the settings that we are currently using in the WordPress SEO plugin:
    Pages: %%title%% | %%sitedesc%%
    Posts: %%title%% | %%sitename%%

    Yet our site name still keeps getting appended to the end of our page title.

    Additionally, I'll add that when we deactivate this plugin the issue goes away. Also we have applied the Twenty Eleven theme and activated this plugin and the issue reappears. So from best we can tell it appears to be related to the plugin.

    Is there anything that we can do to correct this issue or is this a plugin coding issue? Please help us Obi-wan...you are our only hope!!

    I expected the plugin to do this: We expected that only the variables that we have selected for the 'Title templates" would be displayed and not the Site title which is not present.

    Instead it did this: please see above for exact details.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. delebre
    Member
    Posted 2 years ago #

    I am having this same issue, and it's driving me crazy. I like everything about this plugin.. but this flaw is really a killer. All my links in Google too are all appending the post title after the site name and running them together. It looks sloppy! Please help us fix this?

  3. delebre
    Member
    Posted 2 years ago #

    Also, I'm a little frustrated that Joost chooses to point people to these support forums, but seems not to read them often or provide the support needed. Looking at his contact page, he says any attempt to get help through that contact page will result in an immediate deletion of that request. So how are we to get help if this is the only medium to contact him, and he doesn't frequent it?

  4. DavieJ
    Member
    Posted 2 years ago #

    Try making sure "Force rewrite titles" is ticked in the backend under "Titles & Metas"

    If that doesn't work go into themes header.php and remove the title tag that is there:
    <title><?php [...] ?></title>

  5. JaysonFoxx
    Member
    Posted 2 years ago #

    Brilliant....thanks for the help DavieJ! That did the trick!

  6. delebre
    Member
    Posted 2 years ago #

    Changing the header.php caused an

    HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

    When accessing my blog. So that did not work for me.

    I'm certain that one of my plugins had me change to title to:
    <title><?php wp_title(''); ?></title>

    Yet, I don't know which one. How can I have my cake and eat it too? That is to say, can I keep both?

  7. delebre
    Member
    Posted 2 years ago #

    This is absolutely maddening. I use this for my Title information:

    <title>
    <?php
    	if ( is_home() )
    	{
    		echo "Delebre's Blog";
    	}
    	else
    	{
    		wp_title('');
    	}
    ?>
    </title>

    Checking/Unchecking 'Force rewrite titles' has no effect on my posts. They come up as Delebre's Blog - MyBlogTitleOfPostOnSite

    So It's adding - My Blog and then Adding the Title of the post to it and running them together. Even though I have the header changed, it still reverts to an old naming convention. I don't see where I can even change this in the SEO settings.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic