WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
SEO Yoast causing error 404 (45 posts)

  1. Renimaria
    Member
    Posted 1 year ago #

    Hi...I resolved this problem with plugin clearing the option ''Enforce a trailing slash on all URL categories and tags'' on SEO plugin menu ''Permanent links''. Did Work to me. It's only clearing this option.

    Correcting..

    I cleared the option above and too the option enable the sitemap in the plugin. As i use another plugin for sitemap (Google XML Sitemaps Plugin), this option (sitemap) in this plugin is not necessary to me. So, I cleared both options.

    This erro (erro 404 in the categories ) appeared after atualization of plugin for the last version (1.2.5).

  2. caseyry
    Member
    Posted 1 year ago #

    I've tried this but my category-sitemap still does not work when I enable it. Still takes me to a 404.

    How long do sitemaps take to update from WordPress?

  3. theconsultant_
    Member
    Posted 1 year ago #

    im sure its ok to do, i suppose id just hang tight unless of course the site map was showing errors in google webmaster tools

  4. theconsultant_
    Member
    Posted 1 year ago #

    WordPress version: 3.4.1
    WordPress SEO version: 1.2.3

    I did this:

    as per this link http://wordpress.org/support/topic/blog-posts-catergory-links-broken-after-upgrade-to-341?replies=7 but on that site i had already upgraded to 1.2.5 which is a bit flaky when i untick and then tick back again the strip the category base tick box.

    so on another site i went through the whole process again as per my link ( other site doesn't use thesis theme) but i didnt upgrade to wordpress seo 1.2.5 and remained at v.1.2.3

    it works without a problem. the only problem being its not the latest version.

  5. theconsultant_
    Member
    Posted 1 year ago #

    so now this is the last thing that i have tried.

    on my thesis word press site which is on wordpress 3.4.1 and wordpress seo 1.2.5 I flushed the cache, deactivated all plugins, changed the theme. then deleted the wordpress seo plugin ( i downloaded settings). Everything works on my site. Reactivated plugins and reinstalled wordpress seo and uploaded settings. Remains broken unless the strip the category base is left unticked.

  6. caseyry
    Member
    Posted 1 year ago #

    Thanks for the feedback. I will try the methods you mentioned and let you know how it goes!

    Fingers crossed...

  7. caseyry
    Member
    Posted 1 year ago #

    Okay, my temporary solution would be the following to anybody experiencing problems, based on a combination of advice from everybody.

    1.) Disable the Yoast XML Sitemaps feature and install another XML plugin, for now at least. It appears to be somewhere within this that is causing the problems.

    2.) Uncheck 'Enforce a trailing slash', and possibly 'strip category base' too. I am yet to fully discover whether the latter causes problems, but the first definitely does. To be on the safe side, I am using an external category base stripper until it is confirmed as working, as I don't want to risk it. I'll keep you updated when I do try it, though.

    Thanks for the help everyone, and good luck!

    UPDATE:

    It seems to be working with 'Strip Category Base' checked, 'Enforce a trailing slash' unchecked, and Google XML Sitemaps installed.

    Could somebody visit http://ryancaseybooks.com, have a click around the categories, and verify this for me?

    Regards,
    Ryan.

  8. tamlyn
    Member
    Posted 1 year ago #

    Here's my solution: everything works after upgrading WPSEO to 1.2.5 with strip category base checked UNTIL I flush the permalinks by visiting Settings > Permalinks. To reverse this, I can uncheck strip category base, flush permalinks again, then re-enable strip permalinks. However be careful because flushing permalinks breaks it again.

    Hopefully this will be fixed soon. It's kinda ironic that this SEO plugin is resulting in sites being banned from Google!

  9. theconsultant_
    Member
    Posted 1 year ago #

    I've had to disable the plug in completely on my thesis site now. " this is yoast test title" was appearing on all pages, and despite suggestions to flush cache and untick something else, it wouldn't work.
    i had rolled back to WordPress SEO version: 1.2.3 as 1.2. was still causing category issues.

    guess i'm going to have to wait for 1.2.6

  10. theconsultant_
    Member
    Posted 1 year ago #

    i now rank on page 1 for "This is a Yoast Test Title" f*k*ng marvellous.

  11. Arnoud
    Member
    Posted 1 year ago #

    I fixed this by editing each category via /wp-admin/edit-tags.php?taxonomy=category

    At the very bottom of the editing page for a category there is a line: Include in sitemap?:

    By default it is set to "Automatic"
    When I changed that to "Always" the category-sitemap.xml was generated and no more 404 error.

  12. Turismo in
    Member
    Posted 1 year ago #

    Seo yoast..

    Thank you very much for the fix.

  13. daniel.oizumi
    Member
    Posted 1 year ago #

    Thank you very much Arnoud!
    Setting it to "Aways" did the job!

  14. Turismo in
    Member
    Posted 1 year ago #

    Ohh no!
    There is also one problem to fix http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-wordpress-seo-by-yoast-and-wpml-problems-error-404?replies=2

    I hope WordPress seo by Yoast read me and fix it.

  15. rainer23
    Member
    Posted 1 year ago #

    I noticed that all in one seo sends urls of new posts to google like this ...../page/156/ - whereas the real url is like this .../?p=31779.

    Google then realizes that this is a false url and also sees the real url from which this false, created by seo, has sprung up.

    So it is realy ironic that a plugin supposed to optimize does the very opposite, changes the url in such way that google classifies it as broken link (crawling error).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic