WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Search broken after install. (7 posts)

  1. Hayden James
    Member
    Posted 3 years ago #

    Thanks for this plugin it seems great. One issue...

    When I try to enter anything into the wordpress search box I get:

    Fatal error: Call to undefined function is_post_type_archive() in wp-content\plugins\wordpress-seo\frontend\class-frontend.php on line 474

    I'm running the latest version of plugin. How can this be fixed?

  2. Hayden James
    Member
    Posted 3 years ago #

    Dam! Have to disable this plugin for now just got this email:

    You probably know, but just in case you don't, your rss feed is displaying a php error:
    <b>Fatal error</b>:  Call to undefined function is_post_type_archive() in <b>wp-content\plugins\wordpress-seo\frontend\class-frontend.php</b> on line <b>191</b>

    This was since updating yesterday. Rss worked fine until last update. Anywayto downgrade till fixed?

  3. Shaliza
    Member
    Posted 3 years ago #

    I'm having the same problem, but not with RSS feeds. WordPress is installed the root directory & there's a form script I'm trying to install & I'm getting this error:

    Fatal error: Call to undefined function is_post_type_archive() in /wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 191

    It's weird because the script has absolutely nothing to do with WordPress.

  4. Remco Tolsma
    Member
    Posted 3 years ago #

    The WordPress function is_post_type_archive() is available since WordPress version 3.1 as you can see on the page: http://codex.wordpress.org/Function_Reference/is_post_type_archive. To solve your problem i guess you should update WordPress to version 3.1.

  5. Shaliza
    Member
    Posted 3 years ago #

    That can't be the issue since I've had the new version of WP since it was first released. It doesn't matter now though because I installed the script on a different domain which worked out for the best anyway.

  6. toro11
    Member
    Posted 3 years ago #

    The WordPress function is_post_type_archive() is available since WordPress version 3.1 as you can see on the page:

    The plugin compatible upto wp ver 3.1.1
    It should be working fine when you using WP.....2.9,3.0,3.0.5,3.1....

  7. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Next release will fix this, but for now, just upgrade to wp 3.1, it fixes some security issues as well.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic