WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Robots.txt not found under Nginx? (5 posts)

  1. Hector
    Member
    Posted 3 years ago #

    I have installed Nginx as a reverse proxy on top of Apache (running on cPanel, CentOS 5.5, WP 3.05, WP SEO 0.4.1) and my Robots.txt is suddenly unreachable according to Google Webmaster. Do I have to manually create a redirect or edit an .htaccess (which under Nginx doesn't work anyway) ?

    Thanks so much for the advice!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    My plugin doesn't do anything with robots.txt... Don't know what could cause that to be honest.

  3. Hector
    Member
    Posted 3 years ago #

    Ah, I thought the noindexes were written to a robots.txt. I will see what the error is then.

    But now... I recently upgraded the plugin from an earlier version that generated "sitemap.xml" and just come to realise the new one is not creating "sitemap_index.xml". Would that be needing an Nginx redirect? How can I force generate it?

    Thanks mate.

  4. Hector
    Member
    Posted 3 years ago #

    I just found this thread:

    http://wordpress.org/support/topic/plugin-wordpress-seo-by-yoast-sitemap-isnt-created-and-generates-errors-true-wordpress?replies=19

    And I can find the static sitemap.xml but I believe it is outdated from my previous version. What I also gathered is that there is no longer a physical XML but it rather gets generated on demand?

    That would mean I do need the Nginx redirect code or at least the path to the PHP, anyone know?

    Cheers!

  5. TechHamlet
    Member
    Posted 2 years ago #

    In W3Total Cache, under Browser Cache, try to disable "Set W3 Total Cache header" for HTML & XML and then restart Nginx and try again! It worked for me :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic