WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Robots index/follow tag not appearing (5 posts)

  1. CherryHintonBlue
    Member
    Posted 3 years ago #

    Plugin is working brilliantly in general, but one problem: when I tick/untick boxes under "Indexation", I expected a <ROBOTS...> tag to appear, but none does. Should there be one? Otherwise I can't see what those tick boxes do.

  2. fitnessguide67
    Member
    Posted 3 years ago #

    i believe it is broken in this version as it was fine in the previous one.

    All my subpages are getting indexed now with the same title tag which is not good. hope joost can fix before its too late.. :(

  3. bobdye
    Member
    Posted 3 years ago #

    If you'd like to fix it yourself while you're waiting for an official fix:
    1) Open /plugins/wordpress-seo/frontend/class-frontend.php
    2) Find the function "robots"
    3) Somewhere at the beginning (say after the global statement), add:
    $options = get_wpseo_options();

  4. fitnessguide67
    Member
    Posted 3 years ago #

    oh as a sidenote could we have an option to add noydir,noodp to homepage only. can't see why it would ever be needed sitewide :)

  5. CherryHintonBlue
    Member
    Posted 3 years ago #

    Woo hoo! Thanks bobdye. Not sure I'd ever have spotted that! I'm sure joost will reinstate the missing line real soon now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic