WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Removing date from home page description? (5 posts)

  1. J. Brown
    Member
    Posted 2 years ago #

    I noticed that the date of my most recent post/sitemap renewal has been showing up in the description for my homepage in search results. I would like to keep the dates for my posts but remove it on the homepage. I was able to remove the date on my static pages by removing a line of code in my theme page.php file but I'm not sure how to get to the homepage without messing up the header on single posts too (limited code knowledge.) Just wondering if there is a simpler way to make it happen with wordpress SEO.

    Your council is greatly appreciated.
    Cheers.
    J. Brown
    yogijbrown.com

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. kometak
    Member
    Posted 2 years ago #

    I am having the same issue. Have you been able to figure it out?
    Thank you.

  3. J. Brown
    Member
    Posted 2 years ago #

    Hey there-

    There is no way to keep the date on the page without having it show up in the search description. I tried slipping the php function for the date into a javascript to avoid detection from the googlebot (as some recommend in the blogosphere) but I think google is smarter than the seo folks and it didn't work. Apparently, the googlebot does now read the content of scripts too.

    After reading some opinions about how its actually a good thing to have the date on your homepage because it shows that the content is current, I decided to just leave it as it is.

    The only other option is to remove the date of the posts altogether, which some sites opt to do and can be done by altering the "header.php", "index.php" or sometimes "single-post.php" in your theme files.

    Ultimately, I think we may just be a little OCD here and it doesn't really affect how people are viewing are sights in the searches as much as we might think.

    Cheers.

  4. ciscoforall
    Member
    Posted 2 years ago #

    I am facing same problem on my Blog http://www.CiscoForAll.com . I removed the date function from index.php. now waiting for results

  5. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Closing this as resolved as it has nothing to do with my plugin :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic