WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Removed xml sitemaps still returning a 200 status, but look like 40 (2 posts)

  1. milian
    Member
    Posted 1 year ago #

    WordPress version: 3.4.1
    WordPress SEO version:1.2.8.2

    I did this:

    I have certain taxonomies 'noindexed' via this plugin, so I excluded them from the xml sitemap.

    I expected the plugin to do this:

    The links to these taxonomy sitemaps to be removed from the sitemap_index.xml and the excluded taxonomy sitemap urls to return a 404 status.

    Instead it did this:

    The links were removed from sitemap_index.xml, but if you manually browse to the excluded taxonomy sitemap urls they look like a 404 page (Has the 404 template message on the page), but they actually return a 200 status)

    I've seen this happen on 3 different sites now, and can cause a very serious problem. On some of the sites, these 404 looking pages are duplicating the home page under the 404 message. As they are returning a 200 status the pages are getting indexed and thus duplicate home pages are being indexed in Google.

    I thought this was an issue with caching plugins, but have now experienced it on a site with no such plugins. This has happening from with all versions of this plugins right down to version 1.0.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. darrylholland
    Member
    Posted 1 year ago #

    My sitemap isn't working on my Yoast plugin.I tryed deactivating the Super Cache and that didn't work.A message says,Cannot view xml input using xsl style sheet.How do i fix it?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.