WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Remove category base (10 posts)

  1. Talbor Vortex
    Member
    Posted 3 years ago #

    Yoast, thanks for this great plugin!

    Remove category base is not working for me - it gives me 404 error.

    Do I have to do something else besides checking the box "Strip the category base"?

    Thanks in advance, hugs from Brazil. :)

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    What's going wrong is the permalink rewrite... While I have to come up with a better solution for this, for now you'd be best off to go into Settings -> Permalinks (WordPress, not the plugin), and press save. This forces a flush of the rewrite rules and should cause the URLs to work.

  3. Talbor Vortex
    Member
    Posted 3 years ago #

    It worked!

    Thanks, Yoast.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Cool, thanks for letting me know! Set topic to resolved :) If you like the plugin, a 5 star rating on the repository would be appreciated :)

  5. shools23
    Member
    Posted 3 years ago #

    I had the same problem. Flushed out by going to Settings -> Permalinks and hitting save but it didn't work. Any other suggestions?

    I also tried using the "WP no category base" plugin but it still is doing the same thing. The re-write just isn't getting through.

  6. Mark-in-Tallinn
    Member
    Posted 3 years ago #

    Joost, just add this instruction next to the checkbox.
    I also had this problem and got here by googling.

  7. Pushpendra Pal
    Member
    Posted 3 years ago #

    I have the same problem, my all category url's goes to 404 page.
    They should show category related posts when choosing a category, but urls show 404 error.
    Please fix it or suggest me the way to remove 'category-base(/category/)' from posts.

  8. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Can I guess, you're all running WP 2.9 or lower?

  9. webmag
    Member
    Posted 3 years ago #

    I had the same problem in Wp 3.1. The problem came after a update of the SEO plugin. I fixed it by changing the settings in the SEO plugin back to what it was before the update. I think the problem comes from the update resetting the settings under permalinks.

  10. etruxes
    Member
    Posted 2 years ago #

    Hi Yoast, I have this problem right now as well. I'm running WP 3.2.1 and WordPress SEO 0.4.2 I tried the permalink setting refresh and no luck. Any suggestions? Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic