WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Publish post gets slower after installing WP SEO - 0.1.8 (22 posts)

  1. M
    Member
    Posted 3 years ago #

    Hi,

    I know I've read about this somewhere in the threads and it looked like you knew of the issue. Seems that after installing 0.1.8 the publishing of a post becomes a lot slower.

    Wierd is that it gets hung up somehwere in the queries. The post is being published in the backend, but the admin is left with a "in progress" page which usually takes up to 2 minutes to refresh and show the "published" message.

    PS: even so, it is the best SEO plugin I've worked with
    PS 2: I like the auto-generation of titles better (it recognized the format introduced in the Titles page, which isn't happening anymore).
    PS 3: best thing: focus keyword.

  2. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Hey M, let's follow up on this when you're running 0.1.9, coming out in a bit. If that doesn't have the issue I know what might have caused it ;)

  3. M
    Member
    Posted 3 years ago #

    Great! Looking forward to the next version and thanks for addressing this issue.

    Just another thought: do advanced features really have to be in the publish post page?

  4. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Yeah, you can hide them though right? (or actually, they're hidden by default) They have to be there because they apply for that post or page only...

  5. M
    Member
    Posted 3 years ago #

    You're right.. Not everyone's as lazy and happy with the "out-of-the-box" options..:)

  6. M
    Member
    Posted 3 years ago #

    Thanks for the update and the small tweaks that weren't necessary needed (like the new dashboard options ;) ).

    As for the slowness, publishing did get a bit better.

    I would be interested in doing more tests in the admin to see what is taking so long, but I'm not sure what exactely to do to see the queries. Would debug queries (configure in wp-configure) help?

  7. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    It's generating a new sitemap when you publish a post, if you disable that (on the Dashboard -> XML Sitemaps) it'll probably disappear. Not much to be done about that...

  8. M
    Member
    Posted 3 years ago #

    I never use that option because it broke my site when I first installed the plugin.

  9. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    What option?

  10. M
    Member
    Posted 3 years ago #

    XML sitemap (Check this box to enable XML sitemap functionality.) - I had it enabled once and it broke my site then I disabled it and never used it again.

  11. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    You're not using it and yet posting is slowed down? That's weird... It's not doing much more than saving a few variables besides that...

  12. M
    Member
    Posted 3 years ago #

    Yeap. Usually, after the page is loaded and post is published I only see 2 requests ( i have firebug). So you can image why I was wondering about the slowness.

  13. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    That is weird... Well debug queries could help...

  14. M
    Member
    Posted 3 years ago #

    I will try it and come back with information, if I have any.

  15. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Superb, thanks!

  16. M
    Member
    Posted 3 years ago #

    So, I enabled the debug queries option in wp-config and got a 65 MB file in about 15 minutes :(

    Luckyly the only PHP notice from WordPress SEO is this one:
    [06-Dec-2010 14:01:16] PHP Notice: Undefined variable: canonical in /home/domain/public_html/wp-content/plugins/wordpress-seo/frontend/class-frontend.php on line 232

    Not sure if this helps at all, but I am pretty sure now the SEO plugin has nothing to do with slowness.

  17. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    Good. That notice helps, prevented that from occurring now for the next release :)

  18. M
    Member
    Posted 3 years ago #

    Glad to be of help!

  19. BerryReview
    Member
    Posted 3 years ago #

    Hi Joostdevalk,
    I am also running into this slowdown when publishing a post. Takes about 4-5 seconds longer and I do not have XML sitemaps enabled.

    BTW the reason I do not have XML sitemaps enabled is because I thought that might be what is causing the slowdown and did not was to exacerbate the issue. I tried generating the sitemap manually and it took almost 2 minutes though our site has over 8000 articles. The same sitemap tages the Google XML Sitemap plugin only 20 or so seconds and it does it in a background task.
    I also could not find any documentation on how to enable the Google News XML sitemap feature.

    Great plugin BTW. Nice and lean and I seems to have integration with W3 Total Cache.

  20. callmeforsox
    Member
    Posted 3 years ago #

    Yep, I had to disable this plugin because the slowdown timed out my server.

  21. callmeforsox
    Member
    Posted 3 years ago #

    I'm on version .2.1 btw.

  22. M
    Member
    Posted 3 years ago #

    joostdevalk I must say you've done a brilliant job with the latest version of the plugin. It loads more than twice as fast as the AISEOP so I finally switched back to WP SEO :) Phew!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic