WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Plugin causes slow posting (13 posts)

  1. callmeforsox
    Member
    Posted 3 years ago #

    Using version 0.2.1, publishing posts takes extremely long.

  2. callmeforsox
    Member
    Posted 3 years ago #

    Bump? Stopped work on the plugin already?

  3. jtracy
    Member
    Posted 3 years ago #

    ditto. After installing 0.2.1 when I hit Publish for a post, it times out and goes to a 404 error page. However, the post does publish. Strange... When I deactivate it, everything is back to normal and I can publish without any problems again...

  4. Shaliza
    Member
    Posted 3 years ago #

    I'm having the same problem.

  5. vali petcu
    Member
    Posted 3 years ago #

    the only idea i have is that the plugin writes in the custom fields every time it publishes a post. having 13.000 articles takes about 3-4 minutes to do that. hope yoast fixes it soon.

  6. vali petcu
    Member
    Posted 3 years ago #

    i've found a workaround: delete this function in admin/class-metabox.php

    function rebuild_sitemap( $post ) {
        global $wpseo_generate, $wpseo_echo;
        $wpseo_generate = true;
        $wpseo_echo = false;
        require_once WPSEO_PATH.'/sitemaps/xml-sitemap-class.php';
    }

    and start using another sitemap plugin.

  7. ls41
    Member
    Posted 3 years ago #

    Same problem. Takes several seconds to publish the post.

  8. addictionreviews
    Member
    Posted 3 years ago #

    I have encountered the same issue. I have 11,000 posts and it takes roughly 3 minutes to update or add anything. This is not a problem with the pages that I add.

    I have the added concern that when I deactivate the plug in my menu does not work (which are linked to post categories). I would like to try the fix that Vali posted above but I am a little concerned about doing that and would rather hear from Yoast about possible answers.

    You have an extraordinary plug in. Great work and I hope we can fix the issue soon.

    thanks

  9. vali petcu
    Member
    Posted 3 years ago #

    try my fix, it will do until yoast comes with an official fix.

  10. addictionreviews
    Member
    Posted 3 years ago #

    I tried the fix and ended up with errors. I am hoping the fix comes along soon or someone can help me. I have a serious amount of posts to do and update. The time it takes is killing me. Other than the speed though the product is outstanding!

    Please help!

  11. vali petcu
    Member
    Posted 3 years ago #

    look for the rebuild_sitemap function in admin/class-metabox.php and delete the whole lines:

    // When permalink structure is changed, sitemap should be regenerated
    add_action('permalink_structure_changed', array(&$this,'rebuild_sitemap') );
    add_action('publish_post', array(&$this,'rebuild_sitemap') );

  12. addictionreviews
    Member
    Posted 3 years ago #

    THANK YOU!! that worked!

  13. addictionreviews
    Member
    Posted 3 years ago #

    I was dreading the posts that I was doing and very concerned about adding more. BIG HELP! Thanks again vali!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic