WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Permalinks Category Base Problem (19 posts)

  1. svenm73
    Member
    Posted 2 years ago #

    Hello Yoast,

    I have an issue around Permalinks and Pagination with the latest Version (since using 1.2...) of the SEO Plugin.

    Within the Permalink Settings I have stripped the Category Base from Category URLs.
    Now within a category the first page is working fine without the category base. When I want to view the second page I get an 404 error. When I add the category base to the url, I can view the second page.

    It would be great if you could have a look and give me a short feedback wether this is something you can fix within the plugin or if I have to chance something.

    Thanks and best regards
    Sven

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. CompactaBT
    Member
    Posted 2 years ago #

    I've noticed this as well, as have my site's visitors.

    Would be great to find a fix.

  3. Rob Roy
    Member
    Posted 2 years ago #

    mine does it too -- strangely, if I go in and uncheck the box that strips the category base, save, then recheck it and save it again it starts to work again - but only for a few days - I'm not sure what triggers them to break again, but using the steps above fixes it for a few days.

  4. domramsey
    Member
    Posted 2 years ago #

    Exactly the same problem here - and yes, unchecking & re-checking fixes it temporarily for me too.

  5. ryanhudes
    Member
    Posted 2 years ago #

    Same issue happening with my site and this permalink feature...

  6. anducampu
    Member
    Posted 2 years ago #

    I have the same problem. A fix would be nice.

  7. EdwardBlack
    Member
    Posted 2 years ago #

    Yes - same problem here.

    My solution is: Uncheck the 'category base checkbox', save, check the 'category base checkbox' again, save. Now it should work again.

    For bugfixing: I noticed it breakes every time agan when I edit the description of a category.

    Greetings from Germany,
    Edward

  8. anducampu
    Member
    Posted 2 years ago #

    It's working. Thank you

    Greetings,
    Andu

  9. djoseph05
    Member
    Posted 2 years ago #

    This happens to me too. My category links always work fine, but my subcategory links break at random; they suddenly take me to my home page. I uncheck and then recheck the box in the Yeost screen and then the subcategory links work again. I have to keep checking the subcat links because I never know when they will break again.

    This is a nice plugin - I hope there will be a fix,

    djoseph

  10. Chez_Bert
    Member
    Posted 1 year ago #

    I have the same problem on a number of client sites. It just stops working and I can not figure out what causes it to stop. Re-saving the permalink setting in the Yoast SEO plugin fixes it but then it just happens again.

    Jim

  11. cmeinck
    Member
    Posted 1 year ago #

    I too have the same problem. Initially, the resaving of the permalinks worked, but that didn't work this time around. The solution by EdwardBlack above worked. I'm running the development version 1.25 and it doesn't fix the problem.

  12. denutza
    Member
    Posted 1 year ago #

    I was just going to post a similiar bug....Needless to say to fix it, just go to Permalinks and click update (assuming you already have strip category URL set)...You don't have to uncheck it and check it back again.

  13. lawyerseo
    Member
    Posted 1 year ago #

    So... the prevailing opinion is to Uncheck "Strip the category base (usually /category/) from the category URL."

    I'm assuming there is a valid SEO reason to strip the category, it would appear that the "cure" to that SEO problem is worse than the "ailment"?

    if the harm via 404 errors from broken links (broken links that Google Webmaster Tools observes while spidering our site) is worse than leaving the /category/ in
    ... should we just omit that step until Yoast comes up with a fix?

  14. David Radovanovic
    Member
    Posted 1 year ago #

    Ditto here too.

  15. Epox
    Member
    Posted 1 year ago #

    I have exactly the same problem. I know that this is a free plugin, but this kind of bug makes an unsolvable problem for us. Please solve it asap!

  16. Epox
    Member
    Posted 1 year ago #

    For others with the same problem, my temporary solution is the "WP No Category Base" plugin. I've disabled WPSEO"s cat base removing, and intalled this plugin.

    It seems to work well with the installed WPSEO, WP Super Cahce and Redirection.

  17. Lisa
    Member
    Posted 1 year ago #

    I'm having trouble with the Yoast SEO plugin breaking both categories and tags for my Genesis child theme Balance.

    Genesis and Yoast are suppost to play well together, but when I click on categories or tags on the front end I get a 404 error, it does not matter whether I have these checked or unchecked:

    Strip the category base (usually /category/) from the category URL.
    Enforce a trailing slash on all category and tag URL's
    If you choose a permalink for your posts with .html, or anything else but a / on the end, this will force WordPress to add a trailing slash to non-post pages nonetheless.

    Does anyone have a solution for this?

  18. Pedro
    Member
    Posted 1 year ago #

    Hello,

    I just want to say I have the same issues with the sub-categories, that are always broken in my case (returning 404).

    If there is any fix for this I'd gladly use it. Meanwhile I'm using another plugin called WP No Category Base that works fine for me.

    Maybe it helps someone else.

    Thanks,
    Pedro

  19. nims
    Member
    Posted 1 year ago #

    I found the solution ... once you check the "strip category base" and save, go to permalinks and click save. Lets see how long will this hold.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic