WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Permalink Problem After Update (8 posts)

  1. fi3ryfalc0nZ
    Member
    Posted 2 years ago #

    Hi Yoast,
    Thanks for releasing such a wonderful plugin for us all. However, I encountered a problem after the latest update, which caused my permalink to go haywire. As my site is mostly in Japanese romaji, usually my Post Title would be "Watashi no Heya". However instead of appearing as "watashi-no-heya" in the permalink structure, the "no" went missing and became "watashi-heya".

    It was working before I updated to the latest version recently.

    Thanks!

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. fi3ryfalc0nZ
    Member
    Posted 2 years ago #

    Please help!

  3. fi3ryfalc0nZ
    Member
    Posted 2 years ago #

    I disabled and enabled the plugin, but I am still having the same problem. After disabling the plugin, I tried creating a post. I didn't have the problem above. But after enabling it, the problem came back.

  4. Alexander Gieg
    Member
    Posted 2 years ago #

    The plugin has a list of "stopwords" (basically "useless words"). Words in that list get dropped from basically everything SEO-related, and if that list hasn't been translated to the language of your WordPress installation, or if you chose to run your WordPress in English, the default English list is used. The word "no" is in the list, as are "yes", "not", "am", "is", "are", "have", "has", "isn't" etc.

    Currently the only way I can think of for disabling this functionality is to change the return explode(....); line within function wpseo_stopwords() in wordpress-seo/inc/wpseo-functions.php to return array('');, but I don't know if this would cause other issues.

    Maybe Joost could add an option (or filter) for cases such as yours.

  5. Alexander Gieg
    Member
    Posted 2 years ago #

    PS: On the other hand, maye you should consider keeping things as they are. The Japanese particle "no" (for those who don't know, the genitive particle, equivalent to the English "of" and "'s") is, as all the others, quite clear cut examples of SEO stopwords: having them in slugs and the like doesn't help given how search engines already ignore them when typed in a query.

    In fact, were I writing content in Romaji, and were there a stopwords filter in this plugin, I'd use it to add the Japanese particles to the already existing list of English stopwords. :)

  6. fi3ryfalc0nZ
    Member
    Posted 2 years ago #

    I see. Thanks Alexander. I removed the "no" from the stopwords and my problem is fixed! Thanks a lot!

  7. fi3ryfalc0nZ
    Member
    Posted 2 years ago #

    Thanks!

  8. Alexander Gieg
    Member
    Posted 2 years ago #

    You're welcome!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic