WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Page Titles Not Showing Up as Specified (4 posts)

  1. RS80
    Member
    Posted 2 years ago #

    WordPress SEO version: 1.1.9

    I did this: As instructed in the plugin info, I changed the code in my header.php (both theme and my child-theme files) to: <title><?php wp_title(''); ?></title>

    I filled in the Title "Template" field under "Titles" to specify a title as follows: "domain name", then the "|" character, and then the word "Art".

    But when I do an internet search the titles don't show up on the homepage or any other page. It just shows my domain name as the title (same as it did before). However, the titles do show up correctly in the editing window of a page where the SEO panel is displayed, so that tells me that I set it up correctly in the plugin but something in my theme is blocking it possibly?

    I also tried to see if checking that "Force rewrite files" box would make a difference and it didn't. So I have left that unchecked now.

    I have searched the other threads but couldn't find a solution.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Google has yet to respider your site, the last cache date is from may 22nd and has another title than your homepage currently has, so you just have to wait a bit.

  3. RS80
    Member
    Posted 2 years ago #

    Oh, I was wondering if that was it. It's been more than a week so far.
    Thank you very much for your help and quick reply!!

  4. cpolicastro
    Member
    Posted 2 years ago #

    Joost,

    I have a different dilemma with my site titles not showing up properly ( in certain instances ) I am not sure if this is just some of google beginning to choose my page titles for the users or something with my plugin. ( my competitors do not seem to be effected however)

    Here are some examples:

    A - if you do a google search for "kendall roofing" my site should show up as the fifth result but the SERP title is just the name of the page and my company name wich is not the title I have set in my plugin

    B- but if you search " marietta skylight company" you can see my result 4th in organic and the title is showing up properly.

    I was just wondering if there was a bug with the my plugin or if I might just need to work on a more white hat aproach to the titles

    There are hundreds of instances where this is happening and it is eating away at my obsessive compulsive nature

    Thanks for your help in advance, and for everything your plugins have helped me with so far! This is my first website I have built since getting into this last October, and I know I would not be able to have the ROI that I have had without your plugins.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags