WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] open graph not working for video posts (4 posts)

  1. marcfest
    Member
    Posted 2 years ago #

    I'm using Yoast's open graph function. It's generating the tag all right for posts with images, but not for posts with videos. Here's an example: http://www.joy.net/?p=552

    Looking at the source code, there's no og:video information at all.

    Thanks for your help.

    Marc.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Pepperbase
    Member
    Posted 2 years ago #

    Hi,

    Same problem here. I am using the JW player plugin for video. It has an option for open graph as well, however it adds the video properties also to posts and pages where no video is embedded, and therefore does not function correctly on those posts.

    Would be nice if this plugin could check for a video and adjusts the meta tags accordingly. Although this is propably not easy as you need the source of the player and the file (I am using amazon for that).

    Cheers.

  3. Pepperbase
    Member
    Posted 2 years ago #

    Actually. A quick solution would be to let the jw player plugin handle the meta tags for posts with video and yoast for those without.

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Not going to happen within this plugin. A paid module for video seo is coming soon, but I'm not planning on adding that into the core plugin.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic