WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] No editor for robots.txt (6 posts)

  1. Messes
    Member
    Posted 3 years ago #

    Just installed the wordpress seo plugin, and in the "edit files" section of the plugin there is the .htaccess editor but not the robots.txt editor. Also, in the general setting of the plugin I checked the box to Add images to XML Sitemap.
    but dont see a change in the sitemap file. (not sure if i should)

  2. larryjay
    Member
    Posted 3 years ago #

    bump...

    my robots.txt file is blank after editing the indexation settings page. I'm looking at the page:
    mysite.com/robots.txt

    Is there possibly another page created by the yoast seo tool?

  3. Joost de Valk
    Member
    Plugin Author

    Posted 3 years ago #

    The plugin doesn't use robots.txt to enforce all these settings but meta robots tags.

  4. Hendison Scott
    Member
    Posted 2 years ago #

    But Joost, your Feature #8 on the WordPress SEO Plugin feature list
    is "Edit your robots.txt and .htaccess" -
    http://yoast.com/wordpress/seo/

    Also, I'm pretty certain I've seen an editor for the robot.txt file in this plugin for the robots.txt file here before, haven't I?

  5. Hendison Scott
    Member
    Posted 2 years ago #

    OK, I get it now...

    To be clear, The Yoast plugin does nothing to create or ever edit or add to an existing robots.txt file. The robots tags he's referring to just appear in your code.

    If you want to edit an actual robots .txt file from the admin panel, you need to create one manually.

    I just added my generic one below, and an F5 refresh made it appear in the WP admin panel...

    Sitemap: http://www.DOMAIN.com/sitemap_index.xml

    User-agent: *
    Disallow: /wp-admin

    User-agent: *
    Disallow: /wp-includes

  6. nwesource
    Member
    Posted 2 years ago #

    You are right Scott, on some sites there is a robots.txt editor, however my site doesn't have one and I can't figure out how to get it to show up.

    I created one manually and it still doesn't show up the Edit Files tab of the Yoast plugin. I had another Robots plugin installed that perhaps commandeered that part of WP or something...?

    I also get this entry in the .htaccess portion of the Edit Files page:
    “If your .htaccess file were writable, we could do this automatically, but it isn’t so these are the mod_rewrite rules you should have in your .htaccess file.” Then in the box it says, "Options +SymlinksIfOwnerMatch"

    My site is old enough I was running Yoast's plugin back before it had the Robots/HTAccess integration I believe also, when he had the separate Robots Meta plugin...
    _____________________

    Yoast if you get time, I'm sure you have dealt with these issues before so link us up to some details for the resolution(s) if you can! Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic