WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Meta-title and description setting (11 posts)

  1. fredgorski
    Member
    Posted 2 years ago #

    WordPress version: latest
    WordPress SEO version: 1.9 latest, always upgrading

    I did this: I followed instructions clicked the Home-page & Front-end link on title menu from WPSEO, it opened the same page I was. Than I realized maybe page title was the problem. Copied tag %%sitetitle (whatever it is, I copied and pasted).

    I expected the plugin to do this: Have my front-page showing Site´s Title, not page title

    Instead it did this: keeps showing latest article title as meta-title for homepage... And thus appears in google search.

    Background: I was using SEO Ultimate, transfered data with respective plugin, everything right. Deactivated SEO U. and started using WPSEO as default. Problem started than. It´s really kind of annoying, could be much more simple, at least as simple as it was when using SEO Ultimate.

    Everything else is perfect, plugin is really intuitive and helps learning good SEO practice. So please, help me fix it so that I can keep going with this one.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Tim Blake
    Member
    Posted 2 years ago #

    WordPress version: 3.3.2
    WordPress SEO version: 1.9

    I think I'm experiencing the same problem as fredgorski.

    I've followed the guidelines outlined in the article: The Definitive Guide To Higher Rankings For WordPress Sites. According to that article, Section: 1.2.1 "Controlling titles…" there should be a 'Homepage Title template'. Instead, the Titles section now offers me the option to "edit the front page itself." That's all well and good, but when I do, the changes don't take affect. Instead, my front page (Home page) is picking up the content that I placed into the 'blog page'. That too would make sense if I were using my 'blog page' as my 'front page'. However, in the WordPress Admin > Settings > Reading, I've setup my 'Home page' as my 'front page'.

    Something appears to be overriding my 'Reading' settings. Therefore, the 'Front page' believes that it is using the 'Blog Homepage Page Template' instead of the 'Home Page Page Template'.

    Just one other bit of clarification — I created this theme myself. The site is http://blakedesignsolutions.com , in case you want to double-check out my code.

    I really like this plugin and would hate to disable it, but I cannot live with my 'blog title' showing up on my 'Home page'. Please offer any insight as to how I can either get the correct title information to work or override the settings.

    Thanks,
    Tm Blake

  3. fredgorski
    Member
    Posted 2 years ago #

    Now that you mentioned reading settings... As a matter of fact, I ain´t using the static page option. But this is only because my theme makes the changes, and my front-page is a multiple-category page: http://jardimdecalateia.com.br/
    This shouldn´t be a problem, cause it wasn´t a problem using SEO Ultimate (I am sorry I keep mention the concurrent, but it is the truth). This problem only began after installing WPSeo. And, as Tim Blake said, the mentioned article does tell us the existence of a non-existant feature. And this feature is quite important if you´re managing your content instead of blogging it.
    So, as Tim, I beg for urgent reply, otherwise I will be sadly obliged to change plugin.
    Thnx Fred

  4. wellbeingtips
    Member
    Posted 2 years ago #

    Did you check this section in Titles? "Be aware that for WordPress SEO to be able to modify your page titles, the title section of your header.php file should look like this:

    <title><?php wp_title(''); ?></title> "

  5. fredgorski
    Member
    Posted 2 years ago #

    did, but thought it was ok... I cut <?php if(wp_title(' ', false)) { echo ' : '; } ?><?php bloginfo('name'); ?> off, and it worked, thank you so much. Sorry for the inconvenience

  6. fredgorski
    Member
    Posted 2 years ago #

    problem solved

  7. Tim Blake
    Member
    Posted 2 years ago #

    I had already checked the option to "Force rewrite titles", but still had to go in and paste the <title> info into my header.php. Unfortunately, I'm still experiencing the same issue. My 'blog title' is displaying as my 'home page' title when I go to the site.

  8. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Tim, switch to the default theme and see if the same thing happens. I very much doubt it...

  9. Tim Blake
    Member
    Posted 2 years ago #

    Thanks for the suggestion Joost. I don't know why I didn't think of that myself. Anyhow, you were right. The title displays correctly using the Twenty Eleven theme.

    I guess I'll have to dig around in either my Home Page Page Template or my CSS. Either way, the problem doesn't appear to be with the plugin.

    Thanks again for your help.

    This post can be closed.

  10. Tim Blake
    Member
    Posted 2 years ago #

    Just a followup for anyone following this thread.
    After Joost's suggestion and lots of troubleshooting, I narrowed the problem down to a simple php command on my Home Page template. On my Home Page, I was using <?php query_posts("post_per_page=1"); the_post(); ?> to pull in the latest post from my blog. I discovered that if I switched that to <?php get_posts("post_per_page=1"); the_post(); ?>, the Title now displays correctly.

    Thanks Joost for your assistance. I now look forward to implementing the rest of my WordPress SEO.

    Post Closed.

  11. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Perfect! Closing as resolved.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.