WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Meta Description + Title Keep Getting Mixed Up (10 posts)

  1. tekspirit
    Member
    Posted 2 years ago #

    I have a situation where when I edit a post and save it, Yoast SEO either deletes the title and description, or pulls one from a previous post.

    If I edit the post and publish it directly, the title and description are published correctly, but if I need to go in and edit, I must copy the title and description to a text editor, make the changes and preview them, then paste in the yoast title and description and then update (post it).

    I can only guess the database is getting mixed up, and my question is what is the best way to get things lined up properly again.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. tekspirit
    Member
    Posted 2 years ago #

    theme was heatmaptheme pro, now switching to
    catalyst - catalysttheme.com latest version
    yoast seo is latest version

  3. tekspirit
    Member
    Posted 2 years ago #

    I deleted all entries in wp_options that had wpseo, deleted the plugin, reset the cache, logged out, closed browser, rebooted.

    Then I restarted, logged in, added wordpress seo by yoast, and when I add a new post, WordPress SEO by Yoast again puts in a title and description from a previous blog post.

  4. tekspirit
    Member
    Posted 2 years ago #

    Ok, now I've tried an xml export of posts, comments etc...
    deleted everything.

    reinstalled wordpress, imported the xml file...
    added wordpress seo by yoast, went to add a new post

    and the same thing - on a new post, a title and description from a previous post shows up, and everytime I change it, click save draft, the old title+description re-appears.

  5. tekspirit
    Member
    Posted 2 years ago #

    Now it's getting interesting...

    Deleted everything, db, files.
    installed wp from scratch

    unzipped jpgs to the uploads directory...
    unzipped the 28 active plugins and activated.

    created a new post, with WordPress SEO by Yoast title and description, and hit save draft.

    The title and description - disappeared.

    wordpress 3.3.2
    latest yoast.

    Only thing is a corrupted plugin...so next, clean copies of the plugins

  6. tekspirit
    Member
    Posted 2 years ago #

    I'm sure there would be a way to look into all the wordpress table dependencies and fix this puppy, but I don't have the time or interest in that...
    so I have deleted everything...
    reinstalled fresh plugins
    copied posts...

    and WordPress SEO by Yoast is behaving.

    So, I suspect one of the plugins got whacked...at least it wasn't a timthumb!
    (anyone have probs with easy privacy policy plugin? it looked touched)

  7. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    So it looks like it's all nice and dandy now? :) Glad to hear it's fixed.

  8. tekspirit
    Member
    Posted 2 years ago #

    Joost, it was a minor nightmare recreating the posts...just started on the comments (groan) when I realized there are no complicated dependencies in wp...so export, change the id numbers, import...and things are looking virus free and fully operational.

    This is a site with just 30 posts...I'd hate to have one of those 100k content sites and get one of these table corrupting script kiddies.

  9. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Yeah those are a pain. Believe me, I've been there.

  10. Satish Gandham
    Member
    Posted 1 year ago #

    Hi,
    I'm having the same problem.

    Deleting everything is not an option.

    Any idea on whats causing the problem?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic