WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
I HAD to disable canonical functions :( (2 posts)

  1. webjedi
    Member
    Posted 2 years ago #

    I am using the great plugin and discovered it is adding canonicals to pages I DO want indexed.

    Someone tell me if I can do this thru a setting, I could not find the fix in Yoast so I just went into the code and turned off canonicals until I can tweak it.

    Here is an example of my URL structure:

    http://www.example.com/mother_page/fakepage_a/

    When I got to the above URL it is noindex and that's more than 1/2 my site. This page is generated dynamically.

    The canon says this is the canonical URL for all pages like this:

    http://www.example.com/mother_page/

    So my fakepages a,b,c,d,e,f,g etc never get indexed.

    Anyone have similar issues?

    WJ

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. solutionsphp
    Member
    Posted 2 years ago #

    Yes, I have this issue with Yoast SEO and Ecwid shopping cart. By setting the canonical URL, Yoast prevents the Ecwid cart pages from being indexed.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic