WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] How to get rid of post date in meta description (16 posts)

  1. Michael P
    Member
    Posted 2 years ago #

    I just switched over to using the Yoast plugin a few weeks back.

    All of my title/meta descriptions are displaying properly except that I can't stop the date from showing in search results.

    Under "title settings," I ticked the "Force rewrite titles" box and entered the tag %%excerpt%% for the meta description template; for both posts and pages. I made sure everything was saved properly, that was 2 weeks ago.

    The post date is showing up is serps for posts only, not pages.

    If you Google the search term--PROBIOTICS BRANDS-- (from the US), my post from the domain intestinaldysbiosis.com is the first result.

    You'll see the date displayed (which I want to get rid of). It was last cached on Dec. 16th.

    And modifications I made to the title tag and meta description are updated. The capital letters and the >> in the title are an example. I also changed the first letter of each word to capitals in the meta description.

    So I'm sure the meta description has been updated. And I only made those changes a few days ago and they are showing. I tried to remove the post dates over 2 weeks ago.

    I'm not very tech savvy, so if I'm missing something dumb, then I apologize. :)

    I'm using the Suffusion theme.

    Btw, just wanted to say thanks for this great plugin. Definitely better than All in One.

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Michael P
    Member
    Posted 2 years ago #

    Just wanted to add that the date is showing up for every one of my posts on every site, not just the one I mentioned.

    Thanks again.

  3. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    The only way of forcing the date to not show up is by removing it from your single post template.

  4. Michael P
    Member
    Posted 2 years ago #

    Hello Joost. I appreciate the response. But I'm still a little bit at a loss.

    The post date only started appearing when I switched to the Yoast Seo Plugin.

    I used the stock Suffusion settings for a year, and the dates were never displayed.

    I also used All In One Seo, and that also never displayed the post date before the meta description.

    Where should I look in the single post template? Could you give me a heads up?

    Would be much appreciated..

    Mike

  5. Etrain
    Member
    Posted 2 years ago #

    Mike,

    I have the same issue. I've used other plugins and never had an issue with the date showing up. I need to get it removed as it dates my site.

    Joost,

    Can you elaborate on how to make this happen? I'm also slow to remove the post date from the template. Will it re-arrange all of my posts?

    Any help would be much appreciated.

    Thanks
    Evan

  6. Etrain
    Member
    Posted 2 years ago #

    Any update here?

    Mike were you able to figure this out?

    Thanks
    Evan

  7. ciscoforall
    Member
    Posted 2 years ago #

    Same poblem with my blog ciscoforall.com
    please guide

  8. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    There's only one way of doing this: removing the date from the page entirely.

  9. joostwtf
    Member
    Posted 1 year ago #

    There's only one way of doing this: removing the date from the page entirely.

    how do you do this joost?

    [ Please do not bump, it's not permitted here. ]

  10. cmalamed
    Member
    Posted 1 year ago #

    Joost,
    Surprised to hear you say this because up until very recently, your SEO plugin removed the date in the snippet. Now it's back again. Something must have changed in your plugin or in how Google is getting this info.

  11. joostwtf
    Member
    Posted 1 year ago #

    cmalamed do you know how to get rid of this? i'm using a custom template and all of the above got me nowhere... do you edit the yoast settings or do you delete something in the theme editor?

  12. cmalamed
    Member
    Posted 1 year ago #

    I believe you remark out the <date> part of the single page template, but I know you can crash your site by remarking out the wrong code. I suggest you ask the people who made your theme. That's what I'm doing. Also hoping Joost will answer sometime and modify the plugin to what it used to do.

  13. Ocala Website Designs
    Member
    Posted 1 year ago #

    Is it me or for some reason I seem to remember a check box that removed the date from posts in yoast seo ... I can't find it now and was thinking I was going crazy!

  14. Etrain
    Member
    Posted 1 year ago #

    I don't think there is a check box (i've never seen one)...

    I need all the dates on my website because that's what drives which post shows up in specific orders etc...

    I haven't gotten a decent answer on this yet and if I don't get one soon enough I may just have to switch over to a different plugin. I can't have dated meta descriptions in google while trying to sell info to a visitor that is current.

    Look forward to any help.

    Thanks
    E

  15. Ocala Website Designs
    Member
    Posted 1 year ago #

    I found the check box in 1.1.5 or so, it was listed as:
    "Disable date in snippet preview for posts"

    In the general settings, one of my old sites still had the older version. I thought I was going crazy as the date is now showing in the snippet preview. I was under the impression that it also stopped it from displaying in google search results ...

  16. joostwtf
    Member
    Posted 1 year ago #

    Are you sure the date isn't just showing up in the snippet preview only and not in google search results? Someone please confirm this before we switch plugins or go crazy trying to edit the theme template... The date may only be showing up in the snippet preview which doesn't matter.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic