WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Help us improve WordPress SEO (25 posts)

  1. ogenox
    Member
    Posted 1 year ago #

    Hi Yoast,

    I tried to allow your plugin to gather usage stats through PressTrends, but whenever I click on Allow button, nothing happens. Then I clicked Do Not Allow button and pop-up box disappeared, but just for the moment. Whenever I open some page, this box reappears, which is very annoying.

    Please, can you check this, I'm sure that I'm not the only one with this problem.

    Thanks,
    Ogi

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. savvysue
    Member
    Posted 1 year ago #

    I have the same problem. Sure hope there is a fix.

    Thanks.
    Susan

  3. Aditya Pandey
    Member
    Posted 1 year ago #

    Same problem here too. :(
    Nothing works.

    -Aditya Pandey

  4. BrianPate
    Member
    Posted 1 year ago #

    Same here. Quite annoying.

  5. Pete Marovich
    Member
    Posted 1 year ago #

    Ditto!

  6. Raoul
    Member
    Posted 1 year ago #

    Yes, it's very annoying, when i create a post > Appears
    When i go to the dashboard > Appears

  7. spherical
    Member
    Posted 1 year ago #

    I'm not getting an "Allow" button. "Do not allow" doesn't work either but...

    You can make it go away temporarily until Joost comes up with a fix by commenting out lines 39 - 53 in /wordpress-seo/admin/class-pointers.php

  8. ogenox
    Member
    Posted 1 year ago #

    Yep @spherical, that is the best way for now. :)

  9. boatgalley
    Member
    Posted 1 year ago #

    A number of us also have a problem that it has totally crashed our backend. Only have a white screen after logging in.

    For anyone else with the problem, you can go to cPanel and rename the wordpress-seo folder (I added "bad") then you can log in and everything is okay . . . except that you have no SEO plugin, but at least you can get into the admin side. Need a real fix.

  10. spherical
    Member
    Posted 1 year ago #

    Update to my post, above, on a temporary fix (1.2.7 update didn't address this issue). Also comment out line 32 in the same file:

    // add_action( 'admin_print_footer_scripts', array( $this, 'presstrends_request' ) );

    This removes the WPSEO_pointers error that shows on some pages.

  11. spherical
    Member
    Posted 1 year ago #

    BTW, this is IN WP v3.4.1. I'm seeing others resolving issues because they are running older versions and upgrading to the current version fixed them. The 1.2.7 plugin update addresses versions 3.3 and older but does nothing for 3.4 and newer.

  12. BrianPate
    Member
    Posted 1 year ago #

    For whatever reason, the 1.2.7 update fixed the issue for me.

  13. jp2112
    Member
    Posted 1 year ago #

    The fix spherical posted works. Hopefully this will be fixed (for those of us on WP 3.4.1) in a later version.

  14. ogenox
    Member
    Posted 1 year ago #

    For whatever reason, the 1.2.7 update fixed the issue for me.

    For me too, after 5 clicks. :)

  15. mikeheller
    Member
    Posted 1 year ago #

    1.2.7 is still broken for me.

  16. Virendra
    Member
    Posted 1 year ago #

    This message is really very annoying. It appears on every page load, whether or not it is related to the plugin.

    To disabled this I manually edited the plugin file, and now I don't see it again :)

    I just commented line 32 in file wp-content/plugins/wordpress-seo/admin/class-pointers.php

    Here is the updated code.

    if ( !isset( $options['presstrends'] ) ) {
    	// add_action( 'admin_print_footer_scripts', array( $this, 'presstrends_request' ) );
    } else if ( !isset( $options['ignore_tour'] ) || !$options['ignore_tour'] ) {
    	add_action( 'admin_print_footer_scripts', array( $this, 'intro_tour' ) );
    	add_action( 'admin_head', array( $this, 'admin_head' ) );
    }
  17. Silent Reader
    Member
    Posted 1 year ago #

    @Virendra:
    My problem solved. Add "//" only.

    Thanks.

  18. sdveirs
    Member
    Posted 1 year ago #

    @Virendra:
    THANK GOD, lol. I appreciate the info.

    @Silent Reader - doh! I did not understand the // comment until now. Oh well thanks anyway!

  19. utnalove
    Member
    Posted 1 year ago #

    I can see you were having this issue with the 1.2.7 version.
    I didn't notice this problem before. Today I updated to 1.2.8.1 and I started to see this message: http://img9.imageshack.us/img9/7899/seol.png

    There is not allow/do not allow buttons at all.

    Does anybody know what the root cause is?

  20. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    Hey utnalove, thx for that screenshot, can you tell me which other plugins you have running? You can save the settings on the SEO -> Dashboard page, that should also make the popup go away. Sorry for the inconvenience, no clue what's causing this!

  21. happymob
    Member
    Posted 1 year ago #

    Joost - had the same issue at utnalove...your fix in the SEO dashboard turned it off. Here are my other plugins in case it would help:

    -Akisment
    -Comment Probation
    -Similar Posts
    -W3 Total Cache

    Thanks for being awesome.

  22. utnalove
    Member
    Posted 1 year ago #

    Thanks, after saving the popup went away.

    Advanced Access Manager
    Akismet
    CodeStyling Localization
    Comment Reply Notification
    Contact form 7
    Contextual Related Posts
    Decent Comments
    Exploit Scanner
    Faster Image Insert
    FD Feedburner Plugin
    Google Analytics for WordPress
    Google XML Sitemaps
    IdeaWebServer / LiteSpeed workaround
    One Click Close Comments
    RSS Manager
    Shadowbox JS
    Simple Sitemap
    Social Media Widget
    Top Commentators Widget
    Twitter Facebook Social Share
    Ultimate TinyMCE
    Visitor Maps and Who's Online
    Visitor Maps Extended Referer Field
    W3 Total Cache
    WordPress File Monitor Plus
    WordPress SEO
    WP-Cumulus
    WP-DBManager
    WP-Mail-SMTP

    :)

  23. Silent Reader
    Member
    Posted 1 year ago #

    @sdveirs:
    :D :D
    Code "//" disable script. After // is just comment line in PHP line 32 ...class-pointers.php
    or in line 2 @Virendra: updated code

    <?php
    // Silence is golden - Example code after // is read as text/comment
    ?>
  24. Oscar Cabrera
    Member
    Posted 1 year ago #

    Gud am Joost. Kindly extend a helping hand. My problem is: when I clicked update to wordpress seo pro i got an error message and can't open wordpress anymore. Maybe it also has something to do with changing my theme in the middle of using your plugin.
    This is the message I got:
    Fatal error: Call to undefined function update_options() in /home/fastphot/public_html/wp-content/plugins/wordpress-seo/admin/class-admin.php on line 441
    Thank you so much and more power to you.

  25. freedomchic
    Member
    Posted 1 year ago #

    @Virendra : Thank you for breaking it down, followed the exact code and it worked perfect!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags