WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Google Webmaster xml sitemap appears to be an HTML page error messa (5 posts)

  1. MichaelKalo
    Member
    Posted 2 years ago #

    Hello,

    Not sure why I keep getting this error message when I enabled the Yoast XML Sitemap function two weeks ago. When I checked it on Google Webmaster I keep getting a Google error message "Your Sitemap appears to be an HTML page. Please use a supported sitemap format instead." Additionally when I click on that site map http://www.synergybyjasmine.com/sitemap_index.xml I get "This XML Sitemap contains 0 URLs."

    I was using a Google XML Sitemap plugin by Arne Brachhold, but deacitvated it to try the Yoast SEO plugin. I have also seen a huge increase in rel canonical ntoices from SEO Moz and can't figure out if its a WP issue or something wrong with my site. I was hoping enabling the xml function on the Yoast SEO plugin would allow more pages to be indexed, and might help reduce those canonical notices as well.

    Thank you,

    Michael Kaloudis

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Something is going extremely wrong on your site, could you please, to test what's happening, disable all plugins, switch to the default theme and see if this still occurs?

  3. MichaelKalo
    Member
    Posted 2 years ago #

    Hi Joost,

    I updated to the most current version of your plugin and I am using WP 3.3.2 with the Headway theme 2.0.13 I am also using two cache plugins; W3 Total Cache 0.9.2.4 and WP Super Cache 1.1. When I deactivated W3 Total cache, I was able to see 4 xml sitemaps. However, I was trying to improve site speed and http://www.webpagetest.org/ mentioned the W3 plugin.

    W3 Total Cache
    I followed your steps in a prior post post and added the following even though I didn't have the "Do not process 404 errors for static objects" selected.

    sitemap(_index)?\.xml(\.gz)?
    [a-z0-9_\-]+-sitemap([0-9]+)?\.xml(\.gz)?

    I had Browser Cache>>HTML & XML>> HTML Minify settings "inline CSS minification and Inline JS minification selected" and deselected those two. Whether I have the "Do not process 404 errors for static objects with WordPress" selected or not, I still cannot view your sitemaps when W3 is activated.

    I am keeping this plugin deactivated so Google can begin indexing your sitemaps. Would that help out at with the canonicals? Any ideas why this plugin doesn't seem to want to work with yours? Overall, I haven't seen any real site speed improvement using W3, has anyone else?

    Thank you,

    Michael Kaloudis

  4. Joost de Valk
    Member
    Plugin Author

    Posted 2 years ago #

    Running WP Super Cache AND W3 Total Cache is bound to give issues.... Pick one and remove the other.

  5. ajbarndt
    Member
    Posted 2 years ago #

    I am having the same problem. But am not running those plug ins. I disabled everything and switched back to the default theme and still it didn't work. I run almost the exact same plug ins on another of my blogs and it works fine. but not on this one. Any ideas of anything else i can try?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic