WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Google Webmaster Unable to Index Site After Sitemap Submittal (2 posts)

  1. Brian Bowman
    Member
    Posted 2 years ago #

    Hi,

    Weird, but I can't seem to get my site properly indexed. When I check the settings - all look ok.

    In WordPress, my SETTINGS > Privacy is set to allow search engine access/indexing.
    In Yoast SEO my XML Sitemap is enabled...and it IS creating the XML site map - as seen here: http://www.knoxvillejobs.com/page-sitemap.xml

    My problem is that Google says it can't index my site due to the Robots.txt file. Yet, when I look at the file here: http://www.knoxvillejobs.com/robots.txt in cPanel - I don't see that file there. So, I created it locally and uploaded it and now it IS showing up. But, same outcome: Googlebot can't index it due to my Robots.txt file setting.

    Finally, I have WordPress set to default the home page to a page I created. That page is also set to full allow the page in Yoast SEO setting.

    Any insight into why I can't get my site to be indexed?

    Much thanks,

    Brian

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. skipshean
    Member
    Posted 2 years ago #

    +1 on this -- in google webmaster tools, I'm getting a 404 error on the submission of the sitemap, even though I can navigate to it.

    Is it possible that the "friendly" formatting instead of just raw XML is causing this?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic