WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
Google webmaster does not report any Sitemaps (9 posts)

  1. scrambler
    Member
    Posted 2 years ago #

    I recently decided to use WordPress SEO from Yoast.
    I have configured the whole plugin, including turning on the Sitemap (which I can see by clicking the XML Sitemap button in the XML Sitemaps page).
    But when I go to Google Webmaster tool where my site is registered, In Site Configuration > Sitemaps, it shows zero sitemaps.
    I do see that the robot.txt is active, but it looks like the Plugin is not submitting the sitemap.
    Reading the article below from Yoast, it specifically states that we do not need to submit it because the plugin does so
    http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/

    I also have not put the Google verification code in the dashboard as the site is already verified and Yoast in his article above says there is no need if it is the case.

    Before ignoring that and trying to submit it manually, I was wondering if anyone has any idea/advice on why Webmaster Tool reports no sitemap with Yoast plugin active?

    Thanks

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Katsumi
    Member
    Posted 1 year ago #

    Same here. I'm sure someone could answer, because not many seems to wonder about this.

    Yoast says here http://yoast.com/xml-sitemap-in-the-wordpress-seo-plugin/

    "The index file, sitemap_index.xml, should be submitted to Google Webmaster Tools automatically if you have the ping setting for Google on."

    So where should I activate the ping setting he's talking about? The Plugin setting page for the sitemap says that google get pingend automatically...

    In a nutshell: I'm confused as well ;)

  3. scrambler
    Member
    Posted 1 year ago #

    There is no Ping google option, just bing and ask, which means the ping google is automatic if the enable sitemap is checked, so you are right to be confused :)

    I ended up submitting the sitemap manually...

  4. masomh
    Member
    Posted 1 year ago #

    @scrambler: I also just manually added the sitemap by submitting the name of the file itself and the webmaster tool found 65 errors. Did you have this same problem with installing your sitemap manually? How did you do it?

  5. scrambler
    Member
    Posted 1 year ago #

    I submitted the sitemap_index.xml in Webmaster Tools > Optimization > Sitemap
    No errors. When I go back there it shows pages and images ubmitted and pages / images indexed

  6. masomh
    Member
    Posted 1 year ago #

    Unfortunately, it is giving me lots of errors (for every line of the xml) file. I installed my WP folder in a subdirectory: http://www.paintinggroup.com/wp - however, I followed instructions to fix the index file and .htaccess file to point to the correct permalink structure. I think that has something to do with all those errors. I had to end up using google xml sitemaps instead of Yoast's SEO plugin. Any advice or am I doing something wrong?

  7. scrambler
    Member
    Posted 1 year ago #

    I too setup my site in a sub folder. To put it online, I simply edited the .htaccess file according to that post
    http://www.bluehostforum.com/showthread.php?24270-How-to-make-a-subfolder-the-default-website-without-showing-subfolder-in-URL

  8. bjsref2012
    Member
    Posted 1 year ago #

    I also have the same issue "scrambler" pointing out.. My sitemap is not submitted to google as well... How come we don't get an answer from the developer about this? It seems to be a problem many having.

  9. joecap1
    Member
    Posted 1 year ago #

    I get errors in the video sitemap after manually submitting to google....what do we do?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic