WordPress.org

Ready to get started?Download WordPress

Forums

WordPress SEO by Yoast
[resolved] Google Results Snippet not displayed correctly after update (6 posts)

  1. DavidAltmann
    Member
    Posted 1 year ago #

    Hi

    Not sure if it has to do with the Plugin but after I made one of the recent updates I see that my results snippet isn't displayed correctly (wanted to add screenshots but it's not possible as I see). If you go to the German version of google (www.google.de) and google for

    kohlenhydrate tabelle

    (without and dashes or "" etc) you should find my site http://www.kohlenhydrate-tabellen.com on first page, rank 1. You can see that the expression Kohlenhydrate Tabelle appears as "Kohlenhydrate TabelleKohlenhydrate Tabelle ..."

    In the plugin settings under Title & Meta it seems ok.

    Any solution available?? According to statistics it does some noticable damage to my traffic...

    Thanks in advance!
    David

    http://wordpress.org/extend/plugins/wordpress-seo/

  2. Joost de Valk
    Member
    Plugin Author

    Posted 1 year ago #

    David, please read the FAQ next time before posting. Also, I just searched and it looks exactly like you'd want it to me:

    http://uploads.yoast.nl/kohlenhydrate_tabelle-20120615-102818.png

  3. DavidAltmann
    Member
    Posted 1 year ago #

    Hey Joost

    Thanks, and sorry for not having looked into the FAQs... :/

    Two things:
    I) The way you see it in your screenshot is exactly how it's supposed to *not* appear, i.e. the term kohlenhydrate tabelle is *not* supposed to appear two times in a row...

    II) In the FAQs it suggests force rewrite but to do it if "you know what you're doing": well, that sounds to me like something that a non-techy shouldn't do :) I am a bit hesitant therefore of doing it but just gave it a try. Let's see what happens. Editing the header.php code though seems the even more likely-to-mess-something-up option :)

    Regards,
    David

  4. Redhotbasil
    Member
    Posted 1 year ago #

    Hi David,

    Did you ever get a solution, I'm experiencing the same problem.

    Thanks
    Roy

  5. Redhotbasil
    Member
    Posted 1 year ago #

    I did try force re-write and editing header.php but neither made any difference.
    Thanks
    Roy

  6. daveslc
    Member
    Posted 1 year ago #

    I am getting a similar problem.
    WP SEO is using the photo description for the meta description instead of the default first few lines of the posts.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic